Welcome to the JReport Tutorial

Thank you for your interest in JReport, the leading Embedded Reporting Solution for Java Applications. With JReport, intuitive and sophisticated reporting can be customized and integrated as a natural extension of any application.

This guide is intended to provide an overview of the JReport solution, embedded reporting concepts, and detailed step-by-step lessons on using JReport. To allow for lessons to be completed in a reasonable time frame, not all of the features of JReport are covered.

This guide contains three parts:

- **Part I: JReport Overview and Setup**
  This part briefly introduces reports and JReport.

- **Part II: Quick Start**
  This part introduces the most powerful yet easy-to-use web tools of JReport: JDashboard, Visual Analysis, Web Report Studio and Page Report Studio.

- **Part III: Advanced Reporting**
  This part talks about some advanced reporting features of JReport: how to use JReport Designer to create data resources and use the resources to build reports; how the resources are published to JReport Server and managed on the server, and so on.
This version of the JReport Tutorial is developed and written for Windows. File names and paths, sample JSP code, and screen shots in this guide are based on the Windows operating system. However, you can get a Unix version of the JReport Tutorial by changing the paths to the Unix format.

If you encounter any technical issues that prevent completion of the tasks outlined in this guide, please do one of the following:

- Contact our technical support department at http://www.jinfonet.com/contact-support/, available 24 hours a day, seven days a week. This service is available free of charge to registered evaluators for up to 30 days after you receive the JReport Evaluation package.

- Search the JReport Knowledge Base for issue resolution.

Click the right arrow (➡️) below to begin reading the first track.
Part I: JReport Overview and Setup

This chapter provides an overview of JReport. It contains the following sections:

- Who Uses JReport?
- What Is a Report?
- Lifecycle of a Report
- JReport Product Overview
- JReport Sample Reports
- Setting Up JReport on Your System

Click the right arrow (→) below to begin reading the chapter.
Who Uses JReport?

JReport delivers an enterprise-wide solution. Therefore different types of users throughout your organization will use JReport. Each type of user will be able to understand the features and find value in JReport as it relates to their job function or reporting requirements.

There are five general types of JReport users. Each type of user can focus on specific areas of this tutorial as described below:

- **Business Analyst**

  If you are a business analyst, you should understand how JReport Page Report Studio and Web Report Studio allow you to create a special category of reports called ad hoc reports. Unlike the predefined reports in JReport Designer, you build these reports in the runtime environment based on a data model built and published by a report developer.

  You can also create a dashboard rather than a web report or page report, using predefined data components with JDashboard, or use the WYSIWYG product JReport Visual Analysis to visualize the result of every step of your work.

  Focus on tracks in **Part II: Quick Start**.

- **Report Developer**
If you are a report developer, you will use JReport Designer, JReport's visual design environment. This intuitive desktop design tool uses familiar conventions such as property panels, toolbars, style sheets, and drag and drop placement to support every aspect of the report design process. You will quickly become proficient in using the design environment and be able to create professional reports.

Focus on Creating Page reports, Creating Business Views and Creating Web Reports and Creating Library Components in Part III.

- Systems Analyst or Application Server Administrator

If you are a systems analyst or application server administrator, you should know that the JReport solution is managed from a single access point, a web-based console. The JReport solution offers many different deployment options, enabling existing architecture to be leveraged. It can be embedded in a web application via a self-contained WAR/EAR file to provide a reporting service or it can operate as a standalone server.

See Publishing, Running and Administering Resources.

- End User

If you are an end user of reports, you should understand the many different presentation strategies that are available. You can decide which format best delivers the information that you need to make timely and critical business decisions. With JReport, reports can
be viewed and exported to a variety of formats including Applet, HTML, PDF, Excel, XML, RTF, CSV, PostScript, Page Report Result and Web Report Result. JReport's Page Report Result and Web Report Result outputs enable you to interact with and customize report views to obtain exactly the information needed.

See JReport Sample Reports and Creating and Analyzing Ad Hoc Reports.

- Application Developer

If you are a Java application developer, you should understand that both JReport Designer and JReport Server are 100% Java-based tools that run on almost any platform. By offering a robust set of Java APIs, JReport can be seamlessly embedded as a natural extension of your application. In addition to being directly accessed from any Java program via APIs, all reports and functionality can be accessed through HTTP.

Focus on Integrating Reports and Dashboards in Part III.
What Is a Report?

A report is comprised of a report template and a dataset. Reports in JReport can be classified into two categories:

- **Dynamic** - The layout and data to be included is defined at report design time but can also be modified at runtime.
- **Ad Hoc** - Reports that are built on business views at runtime by end users.

Report template

A report template contains static text and graphics as well as placeholders for data.

When a report is in the runtime environment, it connects to the data source associated with the report, executes the query, and applies the fetched data to the template thereby creating a report result file:

![Diagram showing Data Sources, Report Template, and Report Result]

Therefore, each report result represents a unique data set; the one that exists at the time the query is run.

Data sources and datasets

Reports pull data from data sources via queries or business views, and then expose the results to the report designer.

JReport supports the following types of data sources:

- Relational databases through JDBC connections
• Data warehouses

• Java objects

• XML data

• Metadata layers

• User-defined data sources

• Hierarchical data sources

• Web service data sources

• MongoDB data sources

A dataset is the data that the JReport Server returns at runtime from a JReport query or business view.
Lifecycle of a Report

Just like an application, a report has a distinct life cycle. The life cycle contains the following phases:

Phase 1: Determine requirements (report developer)

The first fundamental requirement comes from the intended end users of the report. First, determine who will be the end user of the report and then identify the general purpose of the report. Ask what decisions those users need to make and how often they need to make them (daily, monthly, or other).

Second, you should determine the specific pieces of data that need to be presented in the report and how the pieces map to the data source. Look for common data elements that span multiple reports.

Third, you need to determine the security implications associated with the report. Are there pieces of data that need restricted access? Are there regulatory drivers of the report?

Fourth, determine the expected demand of the report result. Will on-demand report results be necessary or can the report be scheduled? Will report results need to be saved, and for how long?

Fifth, determine the desired report output format. For most Java applications delivery via the Web is the preferred method to present information. However, there may be other end users who don’t need or want Web-based information. Perhaps they require the report be delivered in a standard business format (such as Excel or PDF) or printed.
Phase 2: Develop report template (report developer)

A template can be thought of as a report blueprint that contains static text and graphical objects as well as placeholders to display the data pieces needed on the report. The template definition includes the query that needs to execute to provide the data, as well as the database connection on which to execute it.

Share a report prototype that includes sample data with the end users to see if it meets their requirements and also to obtain feedback on the scope and layout of the report.

Phase 3: Publish report results (system administrator)

Publishing a report template executes the query and merges the resulting data set with the template. The result is a report instance that is available in the context of JReport Server. Report results can be saved to other locations, and in various formats such as HTML, PDF, RTF, and others.

Communicate with the end users regarding how they can access the report and then provide training, as needed. Include a way for the end users to provide feedback; acknowledge feedback and build release schedule.

As report production scales up, the system administrator should monitor performance and apply the appropriate load balancing and security measures.

Phase 4: Access report results (end user and business analyst) and administer (system administrator)

After a report is generated, end users can access it in a variety of ways. A report can be viewed through the JReport Server user console, through a Java application, or routed to a delivery target such as an e-mail address or printer. The business analyst can also build ad hoc reports as needed.

The system administer monitors the report access environment through the JReport Server administration console.
Phase 5: Update report template (report developer)

Collect feedback from the end users to determine any needed improvements to the layout or behavior of the report. Also, modify security as needed (add/drop users) and update data source connections.
JReport Product Overview

JReport delivers operational business intelligence to enterprise applications through powerful embedded reporting.

JReport is a complete Java reporting solution that provides sophisticated enterprise reporting, ad hoc reporting, and data analysis. A 100% Java EE architecture and a rich set of APIs allow JReport to be seamlessly embedded into any application, providing end users with a transparent interface to easily generate reports, share information, and analyze data. With JReport, any report can be made interactive, extending the "life" of a report by allowing users to easily sort, group, navigate, and filter via the Web. This wide range of functionality, including the ability to drill down on data, enables users to quickly derive value from their business intelligence.

JReport’s architecture takes advantage of the portability, scalability, and ease of integration associated with Java EE technology to provide a powerful, flexible reporting solution that fits perfectly within any application architecture.
**JReport Designer** is a Swing-based Integrated Development Environment (IDE) that enables sophisticated report design and presentation of critical business data. It provides an intuitive interface, reusable report components, flexible layout, and a toolset for designing and testing reports. With JReport Designer, you can build reports using simple drag and drop techniques or by using the Report Wizard. Data can be accessed from any data source to design and preview reports in order to deliver information to end users in the most relevant and intuitive manner.
manner. Rapid creation and modification of reports is accomplished by toggling between design mode and view mode where the report will be displayed with the actual dataset. Once report design is complete, the report is published to JReport Server for generation, delivery, and management.

**JReport Server** is a 100% Java report generation and management tool. It enables efficient management, sharing, scheduling, versioning, and delivery of reports and enables reporting to be integrated into the workflow of any Java application. The high-performance engine can scale to any workload. Report results can be saved to a versioning system, sent to enterprise/workgroup printers, or e-mailed. With JReport, reports can be viewed in any modern enterprise format including Page Report and Web Report using any standard browser, HTML, TEXT and standard business documents, such as PDF, Excel, and RTF. JReport Server also supports on-demand, live report creation and modification, providing JReport’s powerful ad hoc solution.

**JDashboard** delivers interactive data visualization and analysis to users. Users can freely choose the objects they want to display in the dashboard, without having to know how these objects were created, what data sources to use, what styles to set, and so on. A dashboard can hold multiple data components so that when browsing the dashboard users are able to see multiple data aspects. Within a dashboard, data components are able to communicate with each other via the message mechanism. This allows actions such as common filters to be applied to all the components of a dashboard even when coming from different data sources.

**Page Report Studio** and **Web Report Studio** enable reports to be accessed through a web browser via Dynamic HTML, or AJAX. With Page Report Studio and Web Report Studio, end users can create their own richly visual and interactive reports for powerful and secure data exploration in a completely self-service manner. Using Page Report Studio and Web Report Studio's advanced capabilities, users can modify reports using dynamic filter and sort, drag and drop columns to and from an existing report, dynamically change chart types, pivot
crosstabs, drill report data to specific groups, and convert report components or create an entirely new report.

**Visual Analysis** is a WYSIWYG product to visualize the result of every work step. Simply by dragging and dropping data fields onto a layout module, users are able to visually create crosstabs and charts step by step. The use of colors, sizes, shapes, and pie slices demonstrates the data in rich aspects.
JReport Sample Reports

JReport comes with many pre-built sample reports. This document describes a few of the sample reports, so that you can see how your own reports may look. The reports that you will be building in this tutorial are simpler than the sample reports.

Report sample 1: Invoice report

This is a typical invoice report, on which end users can perform the filtering, sorting and going functions on key columns by right-click functionality:

Invoice Report

Thank you for your order. Please print this page for your records.

Invoice NO.: 3033
Date: 9/30/2016

Bill to:
Fatima Anderson
Cafe Brazil - Sydney
A.M.P. Centre
Sydney, New South Wales 2000
Australia
+61 (2) 9225 99999

Ship to:
Fatima Anderson
Cafe Brazil - Sydney
A.M.P. Centre
Sydney, New South Wales 2000
Australia
+61 (2) 9225 99999

Payment method:
Credit Card

Order Information:

<table>
<thead>
<tr>
<th>Order #</th>
<th>Shipment #</th>
<th>Order Date</th>
<th>Required Date</th>
<th>Ship Date</th>
<th>Ship Via</th>
<th>Terms</th>
</tr>
</thead>
<tbody>
<tr>
<td>3033</td>
<td>8169</td>
<td>1/23/2014</td>
<td>2/14/2014</td>
<td>On-Board Transport</td>
<td>30 days</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Item</th>
<th>Unit Price</th>
<th>Discount%</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rift Valley Blend</td>
<td>$16.95</td>
<td>10%</td>
<td>$10,083.55</td>
</tr>
<tr>
<td>Espresso Roast</td>
<td>$9.90</td>
<td>10%</td>
<td>$7,110.18</td>
</tr>
<tr>
<td>Tanzania Blackburn</td>
<td>$11.45</td>
<td>15%</td>
<td>$7,786.00</td>
</tr>
<tr>
<td>Mexico Organic</td>
<td>$13.45</td>
<td>20%</td>
<td>$11,739.16</td>
</tr>
</tbody>
</table>

Sub-total: $36,718.90
Shipping: $600.00
Report sample 2: Stock chart

End users can use this report to track performance indices over time. By using the mouse over, end users can instantly view specific metrics for a designated point in time:

![Stock Market Chart]

Report sample 3: Shipment details report

By using web controls in the report, end users can dynamically change the results of the report.
# Shipment Details by Customer

<table>
<thead>
<tr>
<th>Order ID</th>
<th>Order Date</th>
<th>Ship Date</th>
<th>Ship Via</th>
<th>Shipped</th>
<th>Payment Received</th>
<th>Shipping Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>3007</td>
<td>1/12/2014</td>
<td>1/13/2014</td>
<td>United Packing</td>
<td>No</td>
<td>Yes</td>
<td>$100,00</td>
</tr>
<tr>
<td>3365</td>
<td>9/2/2015</td>
<td>9/3/2015</td>
<td>Federal Shipping</td>
<td>No</td>
<td>Yes</td>
<td>$100,00</td>
</tr>
<tr>
<td>3382</td>
<td>10/4/2015</td>
<td>10/5/2015</td>
<td>Federal Shipping</td>
<td>No</td>
<td>No</td>
<td>$100,00</td>
</tr>
<tr>
<td>3400</td>
<td>11/2/2015</td>
<td>11/3/2015</td>
<td>Federal Shipping</td>
<td>Yes</td>
<td>No</td>
<td>$100,00</td>
</tr>
<tr>
<td>3417</td>
<td>12/4/2015</td>
<td>12/5/2015</td>
<td>Federal Shipping</td>
<td>Yes</td>
<td>Yes</td>
<td>$100,00</td>
</tr>
<tr>
<td>3298</td>
<td>5/20/2015</td>
<td>5/21/2015</td>
<td>Express Delivery</td>
<td>No</td>
<td>Yes</td>
<td>$150,00</td>
</tr>
<tr>
<td>3315</td>
<td>6/6/2015</td>
<td>6/7/2015</td>
<td>Express Delivery</td>
<td>No</td>
<td>No</td>
<td>$200,00</td>
</tr>
<tr>
<td>3333</td>
<td>7/8/2015</td>
<td>7/9/2015</td>
<td>Express Delivery</td>
<td>No</td>
<td>Yes</td>
<td>$150,00</td>
</tr>
<tr>
<td>3350</td>
<td>8/6/2015</td>
<td>8/7/2015</td>
<td>Express Delivery</td>
<td>No</td>
<td>Yes</td>
<td>$200,00</td>
</tr>
<tr>
<td>3368</td>
<td>9/8/2015</td>
<td>9/9/2015</td>
<td>Express Delivery</td>
<td>No</td>
<td>No</td>
<td>$150,00</td>
</tr>
</tbody>
</table>

**Total Shipping Cost** $1,350,00

To see more sample reports, visit [http://www.jinfonet.com/resources/jreport-demo/](http://www.jinfonet.com/resources/jreport-demo/).
Setting Up JReport on Your System

The JReport Tutorial assumes that you have downloaded and installed both JReport Designer and JReport Server on a Windows 10 machine.

The JReport Tutorial also assumes that you are performing the lessons on a Windows 10 machine and therefore operating system specific commands and screen shots reflect this. However JReport can run on multiple platforms.

JReport Designer has the following system requirements:

<table>
<thead>
<tr>
<th>JReport Designer System Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Recommended Requirements</strong></td>
</tr>
<tr>
<td><strong>Minimum Requirements</strong></td>
</tr>
<tr>
<td><strong>OS:</strong> Windows x64, Unix x64, Linux x64, z/Linux64, OS X El Capitan</td>
</tr>
<tr>
<td>Windows, Unix, Linux, z/</td>
</tr>
<tr>
<td>Linux, MacOS Sierra</td>
</tr>
<tr>
<td><strong>CPU:</strong> Intel Core 2</td>
</tr>
<tr>
<td>Intel P4 Xeon 3.0GHz</td>
</tr>
<tr>
<td><strong>Free Memory:</strong> 4 GB</td>
</tr>
<tr>
<td>2 GB</td>
</tr>
<tr>
<td><strong>Free Disk:</strong> 2 GB</td>
</tr>
<tr>
<td>1 GB</td>
</tr>
</tbody>
</table>
**JReport Server has the following system requirements:**

<table>
<thead>
<tr>
<th>JReport Server System Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Recommended</strong></td>
</tr>
<tr>
<td><strong>OS:</strong></td>
</tr>
<tr>
<td><strong>CPU:</strong></td>
</tr>
<tr>
<td><strong>Free Memory:</strong></td>
</tr>
<tr>
<td><strong>Free Disk:</strong></td>
</tr>
<tr>
<td><strong>JDK:</strong></td>
</tr>
<tr>
<td><strong>Browser:</strong></td>
</tr>
</tbody>
</table>

Notes:

- JReport supports Java VMs from Sun and IBM. You can try using other Java VMs, but their compatibility cannot be guaranteed. Jinfonet technical support welcomes any feedback on the use of other Java VMs.

- If you want to use JReport Server on a z/Linux system, you must download the JDK specially used for IBM from http://www-03.ibm.com/servers/eserver/zseries/software/java/ and the version should be at least V7.

- You are not recommended to run JReport in the Internet Explorer Compatibility View mode.
Part II: Quick Start

In this part, we will introduce the most powerful yet easy-to-use web tools of JReport.

**JDashboard** enables displaying multiple predefined library components created from different data sources in one dashboard freely and conveniently. Report components and Visual Analysis templates can also be inserted in dashboards.

**Visual Analysis** is simply used for analyzing data step by step visually by combining text or graphics display type and color/size/pie slice/shape customization.

**Web Report Studio** aims at faster and simpler design and creation of multi-component reports or table reports, easier customization, and better presentation style.

Jump to the corresponding tracks to view detailed lessons:

- **Track 1: Self-service Dashboard with JReport**
- **Track 2: Performing Visual Analysis**
- **Track 3: Creating and Analyzing Ad Hoc Reports**

Before starting this part, make sure your JReport Server is started and the JReport Start Page is opened (for details, refer to Starting JReport Server).

Click the right arrow (➡️) below to begin reading the part.
Track 1: Self-service Dashboard with JReport

Dashboard is a new way of information delivery. Users can create, edit and browse dashboards from the JReport Server user console using JDASHBOARD. With pre-built library components, users can freely choose the objects they want to display in a dashboard, without having to know how these objects were created, what data sources to use, what styles to set, etc. Report data components and Visual Analysis templates can also be inserted in dashboards directly. A dashboard can hold multiple library components so that when browsing the dashboard users are able to see multiple data aspects. Within a dashboard, library components are able to communicate with each other via the message mechanism. This allows actions such as common filters to be applied to all the components of a dashboard even when coming from different data sources so as to achieve data synchronization.

- Task 1: Create a dashboard and insert library components
- Task 2: Insert a report component into dashboard
- Task 3: Synchronize the components
- Task 4: Use a slider to filter on Quantity
- Task 5: Insert a third party gadget (stock widget)
- Task 6: Export the library components
- Task 7: Use the configuration panel to change parameters
- Task 8: Share parameters among components
- Task 9: Insert an analysis template into dashboard
Task 10: Run a report in JDashboard

Task 11: Set a dashboard as the server home page

Note: A JDashboard license for JReport Server is required in order to perform this track. If you do not have the license, please contact your Jinfonet Software account manager to obtain it first.

Task 1: Create a dashboard and insert library components

1. On the JReport Server Start Page, click Dashboards in the Create category.

The JDashbaord window is displayed with a blank dashboard created.
2. Click the **Resources** button on the toolbar to display the Resources panel, which lists all the data resources and components that can be inserted in dashboards.

3. Expand the **Component Library > Public Components > SampleReports** folder and drag **Sales by Category.lc** to the dashboard body.

4. Drag **Crosstab.lc** in the same folder to the right of the first component.

5. Click **on the top right of the Resources panel to hide the panel.**

6. Click the **Arrange** button on the toolbar to align the two library components.

7. Click the **Save** button on the toolbar.

8. In the Save As dialog, replace Dashboard 1 with **Products** in the File Name text box, then click **OK** to save the dashboard into the My Reports folder in the server resource tree.

**Task 2: Insert a report component into dashboard**

Report components created from business views can be inserted in dashboards directly.
1. Click on the toolbar to display the Resources panel.

2. Go to the Reports > Public Reports > SampleReports folder, expand ShipmentStatus.wls and drag TableComp to the dashboard body below the existing components. Hide the Resources panel.

3. Click on the toolbar to align the three library components.
4. Save the dashboard.

**Task 3: Synchronize the components**

In this task, we want to click any value of the Category field in the crosstab to automatically update the chart. This is achieved by delivering a filter synchronization message between the two library components.

1. Right-click on any Category value in the crosstab column header, Blends for example, and select **Send Sync > Filter** from the shortcut menu.

2. The chart automatically receives the synchronization message because it is created based on the same business view as the crosstab and contains the field Category too. To view details of the message, right-click the chart and select **Receive Sync**. The filter message is shown in the Receive Sync dialog. Close the dialog.
3. Click any value in the crosstab column header, for example Bold. The chart is filtered to show data of the Bold category only after it receives the synchronization message.

You may find that the crosstab is also filtered. This is because at report design time, the library component designer has predefined to make it receive a filter message too. You can right-click on the crosstab and select **Receive Sync** to view the details if you want.
4. We will remove the filters from the components. Click the **Clear Filters** button on the toolbar.

5. Click on the toolbar to save the dashboard.

**Task 4: Use a slider to filter on Quantity**

1. Click on the toolbar to display the Resources panel, then from the Toolbox node, drag **Filter Control** to the dashboard body below the table.

2. In the Insert Filter Control dialog, input **Sales Quantity** in the Title text box and select **Range Slider** as the control type.

3. Expand the Select Fields drop-down list. The two business views used by the three data components in the dashboard are listed. You can select a common field in both business views to filter the three data component at the same time via the slider. Here we only want to filter data components that use `WorldWideSalesBV`. 
4. Check **Quantity** in *WorldWideSalesBV*, then click outside of the drop-down list to close it. Click **OK** to insert the slider.
5. Hide the Resources panel.

Next, we will use the slider to show the data for Quantity between 5000 and 8000 only.

6. Uncheck the All checkbox on the slider. Drag the left arrow to set a minimum range 4983 and the right arrow to set a maximum range 8031. The chart and crosstab are filtered. The table uses the other business view so it is not changed.
### Sales by Category

- **$222K**
  - Espresso
  - Exotic
  - Flavored
  - Mild
- **$115K**
- **$42K**

### Sales Crosstab

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Region</th>
<th>Latin America</th>
<th>North America</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Espresso Roast</td>
<td>Sales</td>
<td>41,573.07</td>
<td></td>
<td>41,573.07</td>
</tr>
<tr>
<td></td>
<td>Quantity</td>
<td>5999</td>
<td></td>
<td>5999</td>
</tr>
<tr>
<td>Ethiopia Sidamo</td>
<td>Sales</td>
<td>41,797.91</td>
<td></td>
<td>41,797.91</td>
</tr>
<tr>
<td></td>
<td>Quantity</td>
<td>5714</td>
<td></td>
<td>5714</td>
</tr>
<tr>
<td>Java Dragon Blend</td>
<td>Sales</td>
<td>153,706.60</td>
<td>68,889.15</td>
<td>222,395.75</td>
</tr>
<tr>
<td></td>
<td>Quantity</td>
<td>11428</td>
<td>5107</td>
<td>16535</td>
</tr>
<tr>
<td>Torrefazione Italia</td>
<td>Sales</td>
<td></td>
<td>114,573.60</td>
<td>114,573.60</td>
</tr>
<tr>
<td></td>
<td>Quantity</td>
<td></td>
<td>11966</td>
<td>11966</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td>Sales</td>
<td>237,377.58</td>
<td>68,889.15</td>
<td>420,640</td>
</tr>
<tr>
<td></td>
<td>Quantity</td>
<td>23141</td>
<td>5107</td>
<td>40,214</td>
</tr>
</tbody>
</table>

### TableComp

<table>
<thead>
<tr>
<th>Delivery Time</th>
<th>Shipment ID</th>
<th>Shipper Name</th>
<th>Shipping Cost</th>
<th>Ship Type</th>
<th>Fault Type</th>
<th>Year</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central, USA</td>
<td>Successful</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1/6/2016</td>
<td>8351</td>
<td>Corban Truck Lines</td>
<td>$100.00</td>
<td>Standard</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
<tr>
<td>6/13/2016</td>
<td>8441</td>
<td>MW Shipping</td>
<td>$200.00</td>
<td>Overnight</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
<tr>
<td>9/22/2016</td>
<td>8497</td>
<td>R&amp;B Motor Services</td>
<td>$150.00</td>
<td>2-Day</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
<tr>
<td>1/30/2016</td>
<td>8359</td>
<td>Vault Transport Inc.</td>
<td>$150.00</td>
<td>Standard</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
<tr>
<td>4/26/2016</td>
<td>8417</td>
<td>R&amp;B Motor Services</td>
<td>$150.00</td>
<td>Standard</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
<tr>
<td>6/4/2016</td>
<td>8436</td>
<td>R&amp;B Motor Services</td>
<td>$100.00</td>
<td>Overnight</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
<tr>
<td>1/13/2016</td>
<td>8353</td>
<td>Key Freight</td>
<td>$150.00</td>
<td>Standard</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
<tr>
<td>8/13/2016</td>
<td>8477</td>
<td>Corban Truck Lines</td>
<td>$150.00</td>
<td>Priority</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
<tr>
<td>8/13/2016</td>
<td>8478</td>
<td>Corban Truck Lines</td>
<td>$150.00</td>
<td>Standard</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
<tr>
<td>2/13/2016</td>
<td>8373</td>
<td>R&amp;B Motor Services</td>
<td>$150.00</td>
<td>Standard</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
<tr>
<td>7/27/2016</td>
<td>8467</td>
<td>MW Shipping</td>
<td>$150.00</td>
<td>Standard</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
<tr>
<td>10/15/2016</td>
<td>8517</td>
<td>Key Freight</td>
<td>$150.00</td>
<td>Priority</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
<tr>
<td>8/29/2016</td>
<td>8400</td>
<td>Key Freight</td>
<td>$200.00</td>
<td>Standard</td>
<td>Not Applicable</td>
<td>2016</td>
</tr>
</tbody>
</table>

### Sales Quantity

- Total: 4983
- Total: 8031

- All
7. Save the dashboard.

**Task 5: Insert a third party gadget (stock widget)**

1. Click on the toolbar to display the Resources panel, then drag **URL Frame** from the Toolbox node to the dashboard body on the right of the slider. The Insert URL Frame dialog is displayed.

2. In the Title text field, input *My Stocks*, and in the URL text box, type in `http://edulifeline.com/includes/stocks_widget/`.

3. Click **OK**. The specified web page is then inserted into the dashboard.
4. Hide the Resources panel and save the dashboard.

**Task 6: Export the library components**

1. Click the **Export** button on the toolbar. The Export dialog appears.

2. Select **Customize Layout** from the Layout drop-down list.

By default, all the exportable library components are arranged using a tabular style according to their positions in the dashboard in the Design tab on the right. Each tabular cell can hold no more than one component. Sliders and gadgets cannot be exported so they are not available here. Next, we will change the layout of the components a little bit by removing the crosstab on the right of the chart and adding it below the table.

3. Right-click anywhere in the cell containing the crosstab, select **Remove** from the shortcut menu.
4. Scroll down to the blank cell below the table. Drag Crosstab from the Resources box to the cell.
When exporting tables and crosstabs, by default only the data currently displayed in the dashboard will be exported. In our dashboard the table contains several pages and we can view only one page at a time, that is to say only the currently displayed page will be exported. We want to get the full data of the table in the exported result so we need a further setting.

5. Right-click in the cell holding the table, select Filter from the shortcut menu, then choose the All option and click OK.
6. Click the **Export** button on the toolbar. In the Export dialog, keep the default settings to export the dashboard to a PDF file.

![Export dialog](image)

7. Click **OK**. The exporting process begins. When finished, you can open the PDF file to view the result.

8. Close the Export dialog and save the dashboard.

---

**Task 7: Use the configuration panel to change parameters**

When a library component uses parameters and its configuration panel is enabled, you can make use of the configuration panel to change its parameter values.

1. On the table, place the mouse anywhere on the title bar, then click the **Options** button that appears on the title bar and select **Edit Setting** from the dropdown list to display the configuration panel.
2. Click in the value box for the Shipper parameter. The Enter Values dialog appears.

3. Check the Custom radio button, select **UBS Uniform Logistics** and click ![add button] to add it to the right box, then click **OK**.
4. Click OK in the configuration panel. The table result is then changed based on the parameter value.

5. Save the dashboard.

**Task 8: Share parameters among components**
When two or more library components in a dashboard contain parameters that meet the following cases, the parameters can be shared among them. After sharing parameters, you just need to provide values to one group of the parameters and all related components will be able to receive them.

- The numbers of the parameters in each library component are the same.

- According to the parameter order in each library component, the orders of the parameter data types are the same. For example, the parameter data types in a component are String, Number, and Boolean. If there is another component in which the parameter data types are also String, Number, and Boolean, the two components fulfill the condition of the same parameter data types.

- It is up to users to make sure the to-be-shared parameters contain some common values.

In this task, we will insert two library components having similar parameters and see the difference between before and after the parameters are shared.

1. Click \[ + \] on the dashboard title bar to add a new dashboard. A new tab is created, labeled Dashboard 2.

2. Click \[ \] on the toolbar to display the Resources panel.

3. Expand Component Library > Public Components > SampleReports and drag Count Shipment by Ship Type.lc and Count Shipment by Territory.lc one by one to the dashboard body. Hide the Resources panel.

4. Click the Options button \[ \] on the toolbar and select Share Parameter. The displayed dialog shows that the two library components have shared parameters. Close the dialog.
5. Click the **Enter Parameter Values** button on the toolbar. The Enter Parameter Values dialog lists the following parameters. Close the dialog.
Next we will remove the parameter share between the two components to see how many parameters we need to specify.

6. Click 🔄 on the toolbar and select **Share Parameter**. In the displayed dialog, select either component and click the **Cancel Share** button on the top right, then click **OK**.

7. Click 🔄 on the toolbar to access the Enter Parameter Values dialog again. Now it lists separate pairs of the Start Date, End Date, and Territory/Shipper parameters used by the two library components. Close the dialog.
8. Click on the toolbar to save the dashboard as **Shipment**.

**Task 9: Insert an analysis template into dashboard**

1. Keep the Shipment dashboard active.

2. Click on the toolbar to display the Resources panel.

3. Go to the **Reports > Public Reports > SampleReports** folder, expand **VA Analysis.va** and you can find a VCTObject under it. Drag **VCTObject** into the dashboard body.
4. Save the dashboard.

Task 10: Run a report in JDashBoard

1. Keep the Shipment dashboard active.

2. From the Resources panel, drag **Coffee Sales.wls** in the Reports > Public Reports > SampleReports folder to the dashboard body, then hide the panel.

3. The report is loaded into a separate tab via Web Report Studio.
Task 11: Set a dashboard as the server home page
1. In the web browser, change from the JDashboard tab to the JReport Server Start Page tab.

2. Click Profile in the Manage category.

3. In the General tab of the Profile page, check the Use a Dashboard checkbox for the Home Page option, then click OK. Click OK in the prompt message.

4. Click Resources on the system toolbar, then go to the My Reports folder.

5. Click Shipment.dsh in the folder, the dashboard is loaded into a new JDashboard window.

6. Click on the toolbar and you can see Set as Server Home is enabled on the menu list. Click the option to set the Shipment dashboard as the server home page.

7. Refresh the JReport Console page and a Home label is added beside Resources on the system toolbar. Click it and you can access the Shipment dashboard immediately.
Dashboard Title

Shipment by Ship Type

- 2-Day
- Overnight
- Priority
- Standard

Legend:
- Black: 0 <= Count Shipment ID < 50
- Green: 50 <= Count Shipment ID < 100
- Blue: 100 <= Count Shipment ID < 200
- Cyan: 200 <= Count Shipment ID < 300
- Other

VA Analysis

Total Sales

- Blue: Count Shipment ID < 300
- Purple: Count Shipment ID >= 300
Track 2: Performing Visual Analysis

Visual Analysis is a WYSIWYG product to visualize the result of every step of your work. Simply by dragging and dropping data fields onto a layout module, you are able to visually create crosstabs and charts step by step.

Business views are the data sources used in Visual Analysis.

Task 1: Select a business view

Task 2: Adding data fields

Task 3: Saving the template

Task 4: Filtering the data

Note: A Visual Analysis license is required in order to perform this track. If you do not have the license, please contact your Jinfonet Software account manager to obtain one first.

Task 1: Select a business view

1. On the JReport Server Start Page, click Analysis in the Create category.

2. The Select Data Source dialog lists all catalogs in the current folder and the business views in the catalogs. Go to Public Reports > SampleReport.cat > Data Source 1 and click WorldWideSalesBV, then click OK.
3. The Visual Analysis window will be displayed.
Task 2: Adding data fields

This section demonstrates how to drag data fields to the data presentation area and how to use the legend buttons.

1. In the Visual Analysis, click the Display Type button and then select Bar from the drop-down list.

2. Drag Total Sales from the resources panel on the left to the row control box. The Total Sales field is used to draw the axis in the row header.
3. Drag **Category** to the column control box as the column header.
4. Drag Sales Year right to Category: when an arrow appears on the right, drop the field.

You can also make use of the button to add a field from its drop-down resource list.
5. To replace Sales Year with Sales Quarter, drag Sales Quarter over Sales Year. An arrow will appear above Sales Year (in the center), then drop Sales Quarter.

![Diagram](image)

6. To Remove Category, right-click on it and select **Delete** from the drop-down menu. Or you can simply drag the Category label out of its position to remove it.

![Diagram](image)

7. To mark different regions by color, drag **Region** to the Color button in the legend section.
8. We will sort sales quarters. Right-click **Sales Quarter** and select **Sort**.

9. In the Sort dialog, check the **Sort Using Another Field** option, and then select **Total Sales** from the drop-down list. Click **OK**.
10. Here is the sort result.
11. Hover the cursor on a bar and you will see related information.
12. Drag Sales Month after Sales Quarter.
13. The scrollbar shows and we cannot see the whole chart. Widen the presentation area and select **Fit Visible** from the drop-down list of Normal View on the toolbar so that the bar is fully displayed according to the current space.
14. Next we will use the Pie type to demonstrate the slice-by feature. Since a pie does not need as much space as the above bar, we will change Fit Visible back to Normal View on the toolbar.

15. Click and then select from the drop-down list. Then remove Sales Quarter and Sales Month from the column header by dragging them out of their positions.
16. Move Total Sales from the row header to be the slice-by field by moving it to the button in the legend section on the right. Slice-by decides the angle for the total sales in each region.

![Diagram of a pie chart with regions labeled and slice-by button highlighted.]

**Task 3: Saving the template**

The current data state can be saved as a template. Click on the toolbar. In the Save As dialog, leave the save location be the My Reports folder, type in ProductSales in the File Name text box, and click OK. Next time we will be able to open the template in the My Reports folder in the server resource tree.

**Task 4: Filtering the data**

We will use the Text display type to show the filter feature.

1. Click and then select New from the drop-down menu to start a new Visual Analysis session.

2. In the Select Data Source dialog, select WorldWideSalesBV and click OK.

3. From the resources panel, drag Country to the row header, Category to the column header, and Total Sales.
4. From the resources panel drag **Region** to the Filters panel below. By default all the values are selected.
5. To view the data in Asia-Pacific, uncheck <All> and then select Asia-Pacific. The data will be refreshed to show the countries in Asia-Pacific.

6. Save the template as Sales-text in the My Reports folder.
Track 3: Creating and Analyzing Ad Hoc Reports

JReport features a powerful ad hoc reporting capability, which allows end users and business analysts to create and manipulate ad hoc reports in the JReport Server-powered runtime environment.

There are two types of ad hoc reports in JReport, Web Report and Page Report. Both are created from a business view in a catalog. Business views have the capability of providing multiple hierarchies allowing for automatic drill down and drill up for detailed analysis and slicing and dicing data which is especially powerful using a crosstab component.

Web Report Studio provides the user a very high quality web view of the report with component level navigation commands. It has two ways for creating and working with web reports: standard way and quick start way.

- In the standard way, reports are created using the Web Report Wizard which allows creating complex reports with multiple components in a tabular style layout, and also allows for company logo and titles to be placed on the top of the page for more formal presentation. Using Web Report Wizard the user can easily in a single pass create a multi-component web report, for example, a single pass through the wizard can create a tabular style report with a chart and crosstab followed by the detail information in a
In the quick start way, a table report is created quickly based on the data fields you select in a business view.

Go through the following lessons to learn about the report types:

Lesson 1: Creating a Web Report the Quick Start Way

Lesson 2: Creating a Web Report Using Wizard

Lesson 3: Creating and Performing Data Analysis on Page Reports

Note: A JReport Live license for JReport Server is required in order to perform this track. If you do not have the license, please contact your Jinfonet Software account manager to obtain one first.

Click the right arrow (➡️) below to begin reading this track.
Lesson 1: Creating a Web Report the Quick Start Way

In this lesson, we will create a web report the quick start way and learn about the visualization toolbar which is also available in the standard way.

This lesson contains the following tasks:

- Task 1: Create a web report
- Task 2: Convert the table to a crosstab
- Task 3: Convert the crosstab to a chart

Task 1: Create a web report

1. On the JReport Server Start Page, click Web Reports in the Create category.
2. In the Select Data Source dialog, select **WorldWideSalesBV** from the Resources panel and the data fields **Region**, **Sales Year**, **Total Sales**, and **Category** from the business view to display in the table report. Click **OK**.
3. A table is generated.
Task 2: Convert the table to a crosstab

1. Click on the visualization toolbar on the left to convert the table to a crosstab:
2. We will adjust the fields using the wizard to build a better looking report. Click on the visualization toolbar and the Crosstab Wizard is displayed.

3. In the Rows box, select Sales Year and then click the x button at the top right of the box to remove it.
4. Also remove Category from the Columns box.

5. In the Resources box, browse to the Products category at the bottom and select Category. Then click to add it to the Rows box.
6. Click OK to confirm the changes. A message dialog is displayed asking for your confirmation of the change. Click OK in the dialog. Here we get a new crosstab.

<table>
<thead>
<tr>
<th></th>
<th>Asia-Pacific</th>
<th>Europe, Middle</th>
<th>Latin America</th>
<th>North America</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blends</td>
<td>382,628.05</td>
<td>465,908.75</td>
<td></td>
<td>989,971.63</td>
<td>1,838,508.42</td>
</tr>
<tr>
<td>Bold</td>
<td>25,868.51</td>
<td>687,097.76</td>
<td>228,406.64</td>
<td>357,624.96</td>
<td>1,799,017.90</td>
</tr>
<tr>
<td>Espresso</td>
<td>31,118.30</td>
<td>208,178.32</td>
<td></td>
<td>221,387.98</td>
<td>460,684.61</td>
</tr>
<tr>
<td>Exotic</td>
<td>383,663.19</td>
<td>564,144.13</td>
<td>260,368.02</td>
<td>375,226.26</td>
<td>1,563,401.60</td>
</tr>
<tr>
<td>Flavored</td>
<td>262,157.40</td>
<td>549,083.00</td>
<td>232,502.40</td>
<td>1,042,629.65</td>
<td>2,056,372.45</td>
</tr>
<tr>
<td>Mild</td>
<td>530,759.95</td>
<td>728,323.95</td>
<td>128,555.80</td>
<td>938,589.91</td>
<td>2,324,229.60</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td><strong>1,596,215.39</strong></td>
<td><strong>3,202,735.92</strong></td>
<td><strong>847,832.86</strong></td>
<td><strong>4,425,430.42</strong></td>
<td><strong>10,072,214.59</strong></td>
</tr>
</tbody>
</table>

**Task 3: Convert the crosstab to a chart**

1. There are many chart types available to the crosstab on the visualization toolbar. Click to convert the crosstab to a bar chart:
2. If you'd like to view the data in a different chart type, click another chart type button on the visualization toolbar. Here, we click to change it to a gauge chart.
Lesson 2: Creating a Web Report Using Wizard

In this lesson, we will create a web report using the Web Report Wizard, that is using the standard way of Web Report Studio. The report will contain a table, a crosstab, and a chart.

This lesson contains the following tasks:

Task 1: Create a web report using the wizard

Task 2: Operate on the crosstab

Task 3: Perform on the chart

Task 4: Work with the table

Task 5: Apply a filter

Task 1: Create a web report using the wizard

1. On the JReport Server Start Page, click Profile in the Manage category.

2. In the Profile > Customize Server Preferences > General tab, select the Yes checkbox for Use Wizard for Web Report Studio. Click OK to save the setting. Then in the prompt message box, click OK.
3. Click **Resources** on the system toolbar to switch to the page, then go to the **Public Reports > SampleReports** folder.

4. Click **New > Web Report** on the task bar.

5. The Web Report Wizard appears. In the Page screen of the wizard, select **Template2**, which allows for company logo, company name, and report titles to be defined and added in the report's page header panel. We will keep the current company logo and titles, and just change the report titles. In the Report Title text
6. In the Layout screen, select the **T-Style** layout. In the first tabular row, click the **Click here to select component** link in the left cell, select **Crosstab** from the drop-down menu, select **Chart** for the right cell. For the bottom cell, select **Table** from the drop-down menu.
7. Click Next to go to the Bind Data screen to define data for the three components one by one. We will make the three components use the same business view. From the Data Source drop-down list, select WorldWideSalesBV in Data Source 1.

8. First define the crosstab. Add Region to the Columns box, Sales Month to the Rows box, and Total Sales to the Summaries box.
9. Click Next to define the chart. The default chart type is Clustered Bar 2-D, you can change it by selecting another type from the drop-down list. Here we use the default type.
Add Total Sales to the Bar Length box and Country to the X-Axis box.
10. Click Next to define the table. In the Details tab, add these fields: **Customer Name**, **Product Name**, **Order Date**, and **Total**. In the Group tab, add **Country** as the group by field.
11. Click **Next** to display the Style screen and select **Neutral** as the style.

12. Click **Run** and the report is opened in Web Report Studio.
13. Click the **Save** button  on the toolbar.

14. In the Save As dialog, type *SalesPerformance.wls* in the File Name text field, then click **OK** to save the web report. In the prompt message box, click **OK**.

**Task 2: Operate on the crosstab**

1. First we want to change the style of the crosstab. Place the cursor in the crosstab, when the icon appears at its upper top left, right-click the icon, then select **Apply Style > JReportDemo** from the shortcut menu.

2. We will change the data view from Sales Month to Sales Quarter in the row headers. Right-click the row header which displays months, select **Switch Row > Sales Quarter** from the shortcut menu. The row header now displays quarters.
3. To further view information about the product category in the first quarter of 2015, right-click 2015-Q1 in the row header, select Go to by Value > Category from the shortcut menu. The crosstab now shows the total sales of the product categories in the first quarter of 2015 in different regions.

<table>
<thead>
<tr>
<th></th>
<th>Asia-Pacific</th>
<th>Europe, Middle East, Africa</th>
<th>Latin America</th>
<th>North America</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>2015-Q1</td>
<td>143,640.62</td>
<td>1,079,680.67</td>
<td>57,866.65</td>
<td>446,868.98</td>
<td>1,728,036.90</td>
</tr>
<tr>
<td>2015-Q2</td>
<td>162,289.76</td>
<td>372,233.09</td>
<td>68,689.15</td>
<td>369,140.38</td>
<td>972,352.37</td>
</tr>
<tr>
<td>2015-Q3</td>
<td>179,401.75</td>
<td>248,404.44</td>
<td>80,141.89</td>
<td>663,506.36</td>
<td>1,171,454.46</td>
</tr>
<tr>
<td>2015-Q4</td>
<td>248,390.64</td>
<td>259,842.13</td>
<td>150,283.79</td>
<td>461,129.19</td>
<td>1,130,645.74</td>
</tr>
<tr>
<td>2016-Q1</td>
<td>160,877.39</td>
<td>222,638.63</td>
<td>80,141.60</td>
<td>642,771.12</td>
<td>1,026,428.93</td>
</tr>
<tr>
<td>2016-Q2</td>
<td>249,390.64</td>
<td>281,733.59</td>
<td>150,283.79</td>
<td>808,055.86</td>
<td>1,500,063.88</td>
</tr>
<tr>
<td>2016-Q3</td>
<td>161,424.84</td>
<td>291,597.78</td>
<td>80,141.89</td>
<td>821,341.28</td>
<td>1,354,505.78</td>
</tr>
<tr>
<td>2016-Q4</td>
<td>269,799.74</td>
<td>446,575.73</td>
<td>150,283.79</td>
<td>312,067.26</td>
<td>1,188,726.51</td>
</tr>
<tr>
<td>Total</td>
<td>1,566,215.39</td>
<td>3,202,735.52</td>
<td>847,632.86</td>
<td>4,425,430.42</td>
<td>10,072,214.59</td>
</tr>
</tbody>
</table>

4. The row and column headers can be switched. Click the Rotate Crosstab button on the toolbar.

5. Click on the toolbar to undo the rotation.
A crosstab can be converted to a chart and vice versa. Next we want to convert the crosstab to a chart to view and analyze data from different aspects with different focuses.

6. Place the cursor in the crosstab, when the icon  appears at its upper top left, right-click the icon, then select To Chart from the shortcut menu.

7. In the To Chart dialog, the data fields used in the crosstab are listed. We need to define our chart based on these fields. Clustered Bar 2-D is the default chart type. Add the data fields as follows:

![To Chart dialog with selected data fields](image)
8. Click **OK**. Here is the chart:

![Chart 1](image1)

9. To switch the category and the series values, click the **Swap Chart Groups** button on the toolbar. Resize the chart and it displays as follows:

![Chart 2](image2)

10. Click **Save** on the toolbar to save the report.

**Task 3: Perform on the chart**

1. Point to any bar in the chart and a tip shows up. From the tip we can easily get the data information each bar stands for.
We want to link the chart values to a table which contains detailed information about the values.

2. Right-click on a bar, select **Edit Detail Table** from the shortcut menu.

3. In the Edit Detail Table dialog, add these fields to the right panel concerning the total sales in the countries: **Country**, **Product Name**, **Quantity**, **Unit Price**, **Discount**, and **Total**, then click **OK**.
Now we can view the details about the chart values.

4. Right-click on the highest bar which represents USA and click Go to Detail on the shortcut menu. The following table is displayed showing information about USA.
5. Click on the toolbar to return to the main report.

Since the business view has a defined hierarchy, we can go through data upward and downward directly.

<table>
<thead>
<tr>
<th>Country</th>
<th>Product Name</th>
<th>Quantity</th>
<th>Unit Price</th>
<th>Discount</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>USA</td>
<td>Colombia Nari Supr</td>
<td>386</td>
<td>10.95</td>
<td>30.00</td>
<td>2,956.69</td>
</tr>
<tr>
<td>USA</td>
<td>House Blend</td>
<td>423</td>
<td>9.95</td>
<td>30.00</td>
<td>2,946.19</td>
</tr>
<tr>
<td>USA</td>
<td>Colombia Nari Supr</td>
<td>386</td>
<td>10.95</td>
<td>30.00</td>
<td>2,956.69</td>
</tr>
<tr>
<td>USA</td>
<td>Sumatra</td>
<td>202</td>
<td>10.85</td>
<td>0.00</td>
<td>2,151.30</td>
</tr>
<tr>
<td>USA</td>
<td>House Blend</td>
<td>423</td>
<td>9.95</td>
<td>30.00</td>
<td>2,946.19</td>
</tr>
<tr>
<td>USA</td>
<td>House Blend</td>
<td>423</td>
<td>9.95</td>
<td>30.00</td>
<td>2,946.19</td>
</tr>
<tr>
<td>USA</td>
<td>Brazil Ipanema Bou</td>
<td>57</td>
<td>12.95</td>
<td>30.00</td>
<td>516.70</td>
</tr>
<tr>
<td>USA</td>
<td>Brazil Ipanema Bou</td>
<td>57</td>
<td>12.95</td>
<td>30.00</td>
<td>516.70</td>
</tr>
<tr>
<td>USA</td>
<td>Brazil Ipanema Bou</td>
<td>57</td>
<td>12.95</td>
<td>30.00</td>
<td>516.70</td>
</tr>
<tr>
<td>USA</td>
<td>Brazil Ipanema Bou</td>
<td>57</td>
<td>12.95</td>
<td>30.00</td>
<td>516.70</td>
</tr>
<tr>
<td>USA</td>
<td>Brazil Ipanema Bou</td>
<td>57</td>
<td>12.95</td>
<td>30.00</td>
<td>516.70</td>
</tr>
<tr>
<td>USA</td>
<td>Sumatra</td>
<td>202</td>
<td>10.85</td>
<td>0.00</td>
<td>2,151.30</td>
</tr>
<tr>
<td>USA</td>
<td>Sumatra</td>
<td>202</td>
<td>10.85</td>
<td>0.00</td>
<td>2,151.30</td>
</tr>
<tr>
<td>USA</td>
<td>Sumatra</td>
<td>202</td>
<td>10.85</td>
<td>0.00</td>
<td>2,151.30</td>
</tr>
<tr>
<td>USA</td>
<td>House Blend</td>
<td>423</td>
<td>9.95</td>
<td>30.00</td>
<td>2,946.19</td>
</tr>
<tr>
<td>USA</td>
<td>Sumatra</td>
<td>202</td>
<td>10.85</td>
<td>0.00</td>
<td>2,151.30</td>
</tr>
<tr>
<td>USA</td>
<td>Kona Mountain</td>
<td>320</td>
<td>10.45</td>
<td>0.00</td>
<td>3,344.00</td>
</tr>
<tr>
<td>USA</td>
<td>Jamaican Rum</td>
<td>104</td>
<td>9.00</td>
<td>0.00</td>
<td>936.00</td>
</tr>
<tr>
<td>USA</td>
<td>Jamaican Rum</td>
<td>104</td>
<td>9.00</td>
<td>0.00</td>
<td>936.00</td>
</tr>
<tr>
<td>USA</td>
<td>Jamaican Rum</td>
<td>104</td>
<td>9.00</td>
<td>0.00</td>
<td>936.00</td>
</tr>
<tr>
<td>USA</td>
<td>Jamaican Rum</td>
<td>104</td>
<td>9.00</td>
<td>0.00</td>
<td>936.00</td>
</tr>
<tr>
<td>USA</td>
<td>Colombia El Tambo</td>
<td>80</td>
<td>12.00</td>
<td>0.00</td>
<td>960.00</td>
</tr>
<tr>
<td>USA</td>
<td>Colombia El Tambo</td>
<td>80</td>
<td>12.00</td>
<td>0.00</td>
<td>960.00</td>
</tr>
<tr>
<td>USA</td>
<td>Colombia El Tambo</td>
<td>80</td>
<td>12.00</td>
<td>0.00</td>
<td>960.00</td>
</tr>
<tr>
<td>USA</td>
<td>Colombia El Tambo</td>
<td>80</td>
<td>12.00</td>
<td>0.00</td>
<td>960.00</td>
</tr>
<tr>
<td>USA</td>
<td>Colombia El Tambo</td>
<td>80</td>
<td>12.00</td>
<td>0.00</td>
<td>960.00</td>
</tr>
<tr>
<td>USA</td>
<td>Blue Mountain</td>
<td>104</td>
<td>9.95</td>
<td>0.00</td>
<td>1,034.80</td>
</tr>
<tr>
<td>USA</td>
<td>Blue Mountain</td>
<td>104</td>
<td>9.95</td>
<td>0.00</td>
<td>1,034.80</td>
</tr>
<tr>
<td>USA</td>
<td>Colombia Nari Supr</td>
<td>386</td>
<td>10.95</td>
<td>30.00</td>
<td>2,956.69</td>
</tr>
<tr>
<td>USA</td>
<td>Blue Mountain</td>
<td>104</td>
<td>9.95</td>
<td>0.00</td>
<td>1,034.80</td>
</tr>
<tr>
<td>USA</td>
<td>Blue Mountain</td>
<td>104</td>
<td>9.95</td>
<td>0.00</td>
<td>1,034.80</td>
</tr>
<tr>
<td>USA</td>
<td>Blue Mountain</td>
<td>104</td>
<td>9.95</td>
<td>0.00</td>
<td>1,034.80</td>
</tr>
<tr>
<td>USA</td>
<td>Blue Mountain</td>
<td>104</td>
<td>9.95</td>
<td>0.00</td>
<td>1,034.80</td>
</tr>
<tr>
<td>USA</td>
<td>Blue Mountain</td>
<td>104</td>
<td>9.95</td>
<td>0.00</td>
<td>1,034.80</td>
</tr>
<tr>
<td>USA</td>
<td>Gold Coast Blend</td>
<td>105</td>
<td>11.45</td>
<td>0.00</td>
<td>1,202.25</td>
</tr>
</tbody>
</table>
6. Right-click any country name on the X axis and select Go Up > Region. The chart now displays as follows:

![Chart showing regions]

Next we want to go down from Region to Country, however it is not a reversed process of going up from Country to Region, but applying an additional filter.

7. Right-click Asia-Pacific on the X axis and select Go Down > Country. The chart shows the countries in the Asia-Pacific instead of all the countries.

![Chart showing countries]

8. Click on the toolbar to save the report.
Task 4: Work with the table

1. We first sort the table based on the Total column in descending order. Right-click any value in the Total column and then select Sort > Descend from the shortcut menu.

<table>
<thead>
<tr>
<th>Country</th>
<th>Customer Name</th>
<th>Product Name</th>
<th>Order Date</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Australia</td>
<td>Cafe Brazil - Sydney</td>
<td>Ethiopia Sidamo</td>
<td>8/13/2015</td>
<td>14,652.99</td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney</td>
<td>Ethiopia Sidamo</td>
<td>6/13/2015</td>
<td>14,652.99</td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney</td>
<td>Sumatra-Decaf</td>
<td>8/13/2015</td>
<td>12,884.94</td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney</td>
<td>Sumatra-Decaf</td>
<td>6/13/2015</td>
<td>12,884.94</td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney</td>
<td>Mexico Organic</td>
<td>2/13/2015</td>
<td>11,739.16</td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney</td>
<td>Torrefazione Italia</td>
<td>8/13/2015</td>
<td>11,048.40</td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney</td>
<td>Torrefazione Italia</td>
<td>6/13/2015</td>
<td>11,048.40</td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney</td>
<td>Rift Valley Blend</td>
<td>2/13/2015</td>
<td>10,083.55</td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney</td>
<td>Sumatra Mandheinj</td>
<td>8/13/2015</td>
<td>9,816.00</td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney</td>
<td>Sumatra Mandheinj</td>
<td>6/13/2015</td>
<td>9,816.00</td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney</td>
<td>Tanzania Blackburn</td>
<td>2/13/2015</td>
<td>7,786.00</td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney</td>
<td>Italian Roast</td>
<td>8/13/2015</td>
<td>7,367.25</td>
</tr>
</tbody>
</table>

Next, we want to summarize the total sales for each country group.

2. Right-click any value in the Total column, then select Aggregate On from the shortcut menu.

3. In the Aggregate On dialog, set the function to Sum, then click OK. We can see the total sales for each country group is added in the group header.

The sum of total for Australia:
This operation also creates a dynamic aggregation which is given a default name Sum_Total. You can find it in the Dynamic Resource > Aggregations list in the Resources panel and you can use it again in the report.

Now we want to make the table linked with another report.

4. Right-click on any Product Name value and select Link from the shortcut menu.

5. In the Insert Link dialog, click Browse to select Link.wls in the SampleReports folder. Click OK.
6. Click the More button to show more settings.

7. In the Filter tab, click ☰ above the Components box. In the Choose Component dialog, select Bar Chart in the linked report as the link target and click OK.
8. Repeat the above step to add TableComp to the Components box.

9. Select Bar Chart in the Components box, click the button above the Field Conditions box to add a condition row, then select the Product Name field from the Fields (Primary) and Fields (Linked) drop-down lists to set up the filter condition between the table and the target chart based on the field.
10. Select TableComp in the Components box, check Pass on-screen filters to the linked components and click OK to apply the settings.
11. Select **View Mode** from the mode drop-down menu on the toolbar.

12. Click **Mexico Organic** in the Product Name column of the table, or right-click **Mexico Organic** and select **Show Linked Target** from its shortcut menu. The link.wls report is displayed with the chart filtered to show only data about Mexico Organic.
Yearly Sales by Category

Order Detail

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Total Sales</th>
<th>Total Cost</th>
<th>Total Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arabian Mocha Sanani</td>
<td>$113,041.11</td>
<td>$44,096.00</td>
<td>8320</td>
</tr>
<tr>
<td>Blue Mountain</td>
<td>$119,258.71</td>
<td>$32,413.50</td>
<td>12005</td>
</tr>
<tr>
<td>Brazil Panema Bourbon</td>
<td>$554,319.57</td>
<td>$260,296.76</td>
<td>60817</td>
</tr>
<tr>
<td>Breakfast Blend</td>
<td>$131,432.86</td>
<td>$53,167.00</td>
<td>13450</td>
</tr>
<tr>
<td>Chocolate Hazelnut</td>
<td>$133,520.85</td>
<td>$50,542.96</td>
<td>16904</td>
</tr>
<tr>
<td>Colombia El Tambo</td>
<td>$87,924.00</td>
<td>$27,696.06</td>
<td>7327</td>
</tr>
<tr>
<td>Colombia Nari Supremo</td>
<td>$65,414.21</td>
<td>$31,650.85</td>
<td>8221</td>
</tr>
</tbody>
</table>

The following is the original link.wls for comparison:
13. Click on the toolbar to return to the primary report.

14. Click on the toolbar to save the report.

**Task 5: Apply a filter**
The three data components in the report use the same business view, therefore we can apply filters to them at the same time. Even if they used different business views, as long as they had the same field values from different business views you can still filter all components with a single filter. We can use the Filter panel and filter controls to filter report data and the filters created via the two are referred to as on-screen filters. For the usage of filter controls, you can learn from Creating Web Reports in the Advanced Part. Here we focus on using the Filter panel to dynamically filter report data. When we define the linked report in Task 4, we have enabled the on-screen filters to be passed from primary report to the table component in the linked report, so the filter condition specified via the Filter panel in the primary report will be applied in the linked report when we trigger the link.

We would like to filter data with product names, so we need to add the Product Name field to the Filter panel.

1. Switch Web Report Studio to Edit Mode.

2. Click + on the title bar of the Filter panel on the left, then in the Select Field dialog, select **Product Name** and click OK. The Product Name field is now added in the Filter panel with its values.
3. Click **Mexico Organic** in the Product Name box. The report comes out as follows:
4. Switch to View Mode. Click Mexico Organic in the Product Name column of the table to open the linked report.

This time the table in the linked report is also filtered to show only data about Mexico Organic as the on-screen filter defined in the Filter panel of the primary report is passed to it.
5. Click on the toolbar to return to the primary report.

6. Click on the toolbar to save the report.
Lesson 3: Creating and Performing Data Analysis on Page Reports

Using Page Report Wizard the user can create a single component page report which is viewed in Page Report Studio. Page Report Studio provides the user a page mode view of the report very similar to a printed report.

There are several types of reports in the Page Report Wizard which collect information for you: blank (no component), banded, crosstab, table, and chart. You can add components to or remove them from the report after it is generated by the wizard. In this lesson, we will create a page report that contains three report tabs, and then perform data analysis on them to look at the data in other ways.

Data analysis is a process of evaluating data using analytical/logical reasoning. In JReport, business view elements can be added to existing data components. Business views greatly enhance your ability to discover useful information, draw conclusions and support the decision making process.

This lesson contains the following tasks:

- **Task 1: Create a banded report**
- **Task 2: Create a table report**
- **Task 3: Create a crosstab report**
- **Task 4: Insert a chart**
- **Task 5: Analyze data of a banded object**
- **Task 6: Analyze data of a table**
- **Task 7: Analyze data of a crosstab**
- **Task 8: Analyze data of a chart**

**Task 1: Create a banded report**

1. On the JReport Server Start Page, click Page Reports in the Create category.
2. In the displayed page, select the SampleReports folder and SampleReports.cat catalog file, then click OK.
3. In the New Page Report dialog, type **Customer Orders Report** in the Report Title text field, select **Banded** in the layout box, then click **OK**.

The Banded Wizard appears.

4. In the Data screen, select **WorldWideSalesBV** in Data Source 1 from the Available Data Resources list. Click **Next**.

A page layout ad hoc report is supported by only one business view. The definition of a business view determines what can be
done on a report. Typically this information is communicated to the business analyst who builds the report.

5. In the Display screen, expand the Orders Detail category in the Resources box, add Order Date and Total in it as detail fields one by one by clicking . Click Next.

6. In the Group screen, select Country in the Customers category and click to add it as a group by field, keep Ascend as the sort manner, and then click Next.

7. Skip the Summary screen and click Next, the same to the Query Filter screen.

8. In the Style screen, set the style to ClassicBlue, and then click Finish to create the report.

The report appears as follows in Page Report Studio:
9. Click **Menu > File > Rename Report Tab**.

10. In the Rename Report Tab dialog, enter **CustomerOrders** as the report tab name, then click **OK**.

11. Click the **Save** button on the toolbar.

12. In the Save As dialog, type **CustomerOrders.cls** in the File Name text field, then click **OK**. In the Confirm dialog, click **OK**.

**Task 2: Create a table report**

1. In the current open report window, click the **New Report Tab** button on the toolbar.

2. In the New Report Tab dialog, enter **Current Customers** in the Report Title text field, select **Table (Group Above)** in the layout box, then click **OK**. The Table Wizard appears.
3. In the Data screen of the wizard, select WorldWideSalesBV in Data Source 1, then click Next.

4. In the Display screen, add Customer Name, Phone and CustomerCityStateZip (change its display name to Zip) from the Customers category as the detail fields. Click Next.

5. In the Group screen, add Country from the Customers category as the group by field, keep Ascend as the sort manner, then click Next.

6. Skip the Summary screen and click Next to access the Query Filter screen.

As we would like to focus on customers not in USA, we will apply a filter to the business view. However, we find that there is no predefined filter in the business view, so we will define one.

7. In the Query Filter screen, define the filter as Country != 'USA', then click Next.
8. In the Style screen, set the style to **ClassicBlue**, and then click **Finish** to create the table report.

The table report appears as follows:
9. Click **Menu > File > Rename Report Tab**. In the Rename Report Tab dialog, enter **CurrentCustomers** as the report tab name, then click **OK**.

10. Click the **Save** button on the toolbar. In the Save Report Template dialog, click **Yes** to save the report, then click **OK** in the prompt message window.

**Task 3: Create a crosstab report**

1. In the current open report window, click the **New Report Tab** button on the toolbar.

2. In the New Report Tab dialog, type **Sales Report** in the Report Title text field, select **Crosstab** in the layout box, then click **OK**. The Crosstab Wizard appears.

3. In the Data screen, select **WorldWideSalesBV** in Data Source 1 and then click **Next**.

4. In the Display screen, add **Country** from the Customers category in the Resources box as the row field and **Category** from the
Products category as the column field (keep Ascend as the sort manner for both columns and rows), then add Total Sales from the Orders Detail category as the summary field. Click Next.

5. Skip the Query Filter screen. Click Next.

6. In the Style screen, set the crosstab style as ClassicBlue, then click Finish to create the crosstab report.

The crosstab report appears as follows:
7. Click Menu > File > Rename Report Tab. In the Rename Report Tab dialog, enter Sales as the report tab name, then click OK.

8. Click the Save button on the toolbar. In the Save Report Template dialog, click Yes to save the report, then click OK in the prompt message window.

Task 4: Insert a chart

In this task, we insert a chart into the Sales report created in Task 3.

1. In the current report window, click Menu > View > Toolbox to display the Toolbox panel.

2. Drag Chart to place it under the last row of the crosstab.
The Chart Wizard appears.

3. In the Data screen, select **WorldWideSalesBV** in Data Source 1, then click **Next**.

4. In the Type screen, keep the default chart type **Clustered Bar 2-D** and click **Next**.

5. In the Display screen, add **Sales Quarter** from the Orders Detail category to the Category box and **Product Type** in the Products category to the Series box, then add **Total Sales** in the Orders Detail category to the Show Values box.
6. Click Finish to create the chart. The chart appears as follows:

![Chart Image]

7. Click the Save button on the toolbar. In the Save Report Template dialog, click Yes to save the report, then click OK in the prompt message window.
Task 5: Analyze data of a banded object

1. In the current report window, click **CustomerOrders** from the Go To drop-down list on the toolbar to switch to this report tab.

Now, we want to make the records in each Country group further grouped in product category, and to know the discount.

2. On the left side, close the Toolbox panel by clicking X on the Toolbox title bar, then click **Menu > View > Resource View** to display the Resource View panel.

3. In the panel, expand the **Products** category, drag **Category** to the banded object and drop it as the mouse pointer moves below the Country group header and a tip Group Header appears.

The report tab appears as follows:
4. Drag the **Discount** field in the Orders Detail category to the detail panel of the banded object:

Now the report tab looks as follows:
Next, we will do some adjustments to improve the appearance of the report tab.

5. Right-click the label Customer Orders Report and select Properties from the shortcut menu. Then in the Label Properties dialog, go to the Font tab, check the Bold option and then click OK.

6. Right-click any value of the Order Date field and select Properties from the shortcut menu.

7. In the General tab of the Data Field Properties dialog, set the Format property to MM/dd/yyyy and click OK.

There are two group levels in the banded object, so we will change the background color of the Category group in order to distinguish the two levels.

8. Right-click the group header panel of the Category group and click Properties on the shortcut menu.

9. In the General tab of the Banded Panel Properties dialog, set the Background property to #668cb2, and then click OK to confirm.

Click the Next button on the toolbar (or just simply scroll down the mouse wheel) to navigate to the next page (page 2). Repeat this to navigate to the following pages. There is a large space or gap before each new Category begins. This is caused by a blank Group Footer panel at the end of each category. We will remove the Group Footer panel. Return to the first page.

10. Right-click the footer panel of the Category group and select Hide from the shortcut menu.
11. Now the report tab looks as follows:

<table>
<thead>
<tr>
<th>Order Date</th>
<th>Total</th>
<th>Discount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Australia</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Blends</td>
<td></td>
<td></td>
</tr>
<tr>
<td>08/13/2015</td>
<td>7,367.25</td>
<td>.00</td>
</tr>
<tr>
<td>04/13/2015</td>
<td>898.70</td>
<td>.00</td>
</tr>
<tr>
<td>06/13/2015</td>
<td>7,367.25</td>
<td>.00</td>
</tr>
<tr>
<td>04/13/2015</td>
<td>1,145.00</td>
<td>.00</td>
</tr>
<tr>
<td>Bold</td>
<td></td>
<td></td>
</tr>
<tr>
<td>02/01/2015</td>
<td>99.16</td>
<td>20.00</td>
</tr>
<tr>
<td>Espresso</td>
<td></td>
<td></td>
</tr>
<tr>
<td>02/13/2015</td>
<td>10.18</td>
<td>10.00</td>
</tr>
<tr>
<td>Exotic</td>
<td></td>
<td></td>
</tr>
<tr>
<td>02/13/2015</td>
<td>7,708.00</td>
<td>15.00</td>
</tr>
<tr>
<td>06/13/2015</td>
<td>14,652.99</td>
<td>10.00</td>
</tr>
<tr>
<td>04/13/2015</td>
<td>1,768.95</td>
<td>10.00</td>
</tr>
<tr>
<td>02/13/2015</td>
<td>10,043.55</td>
<td>10.00</td>
</tr>
<tr>
<td>08/13/2015</td>
<td>14,652.99</td>
<td>10.00</td>
</tr>
</tbody>
</table>

Next, we will sort and filter records. The totals will be sorted in ascending order for each group. The records will be filtered by discount. The report will only display orders in which the discount is 30.

12. Click the Sort button on the toolbar to open the Sort dialog.

13. In the Sort dialog, choose Total from the field drop-down list, keep the sorting manner as Ascend, and then click OK to apply the settings.
14. Right-click any value of the Discount field, and on the shortcut menu, click **Filter > 30.00**.

After doing the sorting and filtering, the report tab looks as follows:
In the above two steps, we used two ways to sort and filter the report results: one by dialog and the other by right-click menu command. In fact, both sorting and filtering can be achieved by either way.

We have defined two grouping levels in the banded report: one by Country and the other by Category. Next, we will change one of the grouping criteria: grouping the banded object by Product Type instead of Category.

15. Right-click any of the Category value ("Bold" for example) and click **Drill To > Product Type** on the shortcut menu.
The report result finally changes to:

<table>
<thead>
<tr>
<th>Order Date</th>
<th>Total</th>
<th>Discount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Belgium</td>
<td></td>
<td></td>
</tr>
<tr>
<td>04/01/2016</td>
<td>9,589.97</td>
<td>30.00</td>
</tr>
<tr>
<td>05/04/2016</td>
<td>9,589.97</td>
<td>30.00</td>
</tr>
<tr>
<td>08/01/2016</td>
<td>9,589.97</td>
<td>30.00</td>
</tr>
<tr>
<td>Canada</td>
<td></td>
<td></td>
</tr>
<tr>
<td>05/15/2015</td>
<td></td>
<td>30.00</td>
</tr>
<tr>
<td>07/15/2015</td>
<td></td>
<td>30.00</td>
</tr>
<tr>
<td>01/15/2016</td>
<td></td>
<td>30.00</td>
</tr>
<tr>
<td>09/15/2015</td>
<td></td>
<td>30.00</td>
</tr>
<tr>
<td>11/15/2015</td>
<td></td>
<td>30.00</td>
</tr>
<tr>
<td>France</td>
<td></td>
<td></td>
</tr>
<tr>
<td>03/22/2015</td>
<td>3,916.08</td>
<td>0.00</td>
</tr>
<tr>
<td>05/22/2015</td>
<td>9,500.26</td>
<td>0.00</td>
</tr>
<tr>
<td>07/22/2015</td>
<td>9,500.26</td>
<td>0.00</td>
</tr>
<tr>
<td>09/22/2015</td>
<td>9,500.26</td>
<td>0.00</td>
</tr>
<tr>
<td>11/22/2015</td>
<td>9,500.26</td>
<td>0.00</td>
</tr>
<tr>
<td>01/22/2016</td>
<td>9,500.26</td>
<td>0.00</td>
</tr>
<tr>
<td>03/22/2015</td>
<td>9,542.92</td>
<td>0.00</td>
</tr>
<tr>
<td>05/22/2015</td>
<td>9,542.92</td>
<td>0.00</td>
</tr>
<tr>
<td>11/22/2015</td>
<td>9,542.92</td>
<td>0.00</td>
</tr>
<tr>
<td>01/22/2016</td>
<td>9,542.92</td>
<td>0.00</td>
</tr>
<tr>
<td>03/22/2015</td>
<td>22,288.00</td>
<td>0.00</td>
</tr>
</tbody>
</table>
16. Click the **Save** button on the toolbar. In the Save Report Template dialog, click **Yes** to save the report, then click **OK** in the prompt message window.

**Task 6: Analyze data of a table**

1. Select **CurrentCustomers** from the Go To drop-down list on the toolbar to switch to this report tab.

First, we want to remove the zip information from the table as we think it is not required.

2. Right-click the **Zip** label and select **Remove Column** from the shortcut menu to delete the Zip label and its corresponding DBField.
Next, we will add a group Region, and make its level higher than the existing Country group.

3. From the Resource View panel, drag Region from the Customers category to above the Country group header and drop it when a horizontal blue line appears above the Country group header.

Next we want to add some detail fields to the table. We can do this either by dragging or using the dialog.

4. Drag State from the Resource View panel to the top right boundary of the Phone column. Hover over the right boundary of the Phone table header and drop it when a vertical blue line appears to the right of Phone. This requires careful mouse movements and a steady hand. Click OK in the prompt message.
5. Click blank area in the table, when the icon 🕐 appears at its upper left corner, right-click the icon and select **Insert > Detail Column** from the shortcut menu.
6. In the Insert Detail Column dialog, select **Address 1** from the Customers category and click **OK**. A detail column, **Address 1**, will be added to the right of the State column.

However, we now consider the state information is not very useful because we will care more about the city information. So we can overwrite State with City.
7. Drag City in the Customers category from the Resource View panel to the State column label and drop it:

<table>
<thead>
<tr>
<th>Region</th>
<th>Customer Name</th>
<th>Phone</th>
<th>City</th>
<th>Address 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia-Pacific</td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>New South Wales</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>New South Wales</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>New South Wales</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>New South Wales</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>New South Wales</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>New South Wales</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>New South Wales</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>New South Wales</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>New South Wales</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>New South Wales</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>New South Wales</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>New South Wales</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The report result becomes:

<table>
<thead>
<tr>
<th>Region</th>
<th>Customer Name</th>
<th>Phone</th>
<th>City</th>
<th>Address 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia-Pacific</td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil -</td>
<td>+61 (2) 9225</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
</tr>
<tr>
<td></td>
<td>Sydney</td>
<td>999999</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

8. Resize the Customer Name column by dragging the boundary to the right of the column to make all the customer names in the column displayed entirely.
9. Repeat the resizing step for the Phone and Address 1 columns.

The report result finally changes to:

```
Current Customers

<table>
<thead>
<tr>
<th>Region</th>
<th>Customer Name</th>
<th>Phone</th>
<th>City</th>
<th>Address 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia-Pacific</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Australia</td>
<td>Cafe Brazil - Sydney +61 (2) 9225 99999</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney +61 (2) 9225 99999</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney +61 (2) 9225 99999</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney +61 (2) 9225 99999</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cafe Brazil - Sydney +61 (2) 9225 99999</td>
<td>Sydney</td>
<td>A.M.P. Centre</td>
<td></td>
</tr>
<tr>
<td>China</td>
<td>Java Brewers - Beijing +86 (10) 588 00000</td>
<td>Beijing</td>
<td>3201 China World Tower 1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Java Brewers - Shanghai +86 (21) 220 99999</td>
<td>Shanghai</td>
<td>30th Floor, Shanghai Kerry Center</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Java Brewers - Shanghai +86 (21) 220 99999</td>
<td>Shanghai</td>
<td>30th Floor, Shanghai Kerry Center</td>
<td></td>
</tr>
</tbody>
</table>
```

10. Click the Save button on the toolbar. In the Save Report Template dialog, click Yes to save the report, then click OK in the prompt message window.

**Task 7: Analyze data of a crosstab**

1. Select Sales from the Go To drop-down list on the toolbar to switch to the Sales report tab, which contains a crosstab and a chart.

Since Country is a middle level predefined in the hierarchy Geography of WorldWideSalesBV, we can drill it up or down to the adjacent
2. Right-click any country in the row header, and click **Drill Up > Region**.

Next we want to go down from Region to Country, however it is not a reversed process of going up from Country to Region, but applying an additional filter.

3. Right-click **Asia-Pacific** in the row header, and select **Drill Down > Country** from the shortcut menu. Now, only data of countries in Asia-Pacific is displayed:

We can further drill Country down to State and then to City in this way if necessary. Here, let's leave the crosstab as it is.

4. Right-click **China** in the row header, and select **Drill to by Value > Customer Name**. The crosstab is regenerated to show data of customers in China:

5. Next, we want to pivot the crosstab, namely interchange the rows and columns. Click the **Rotate** button on the toolbar and the crosstab finally changes to:
6. Click the Save button on the toolbar. In the Save Report Template dialog, click Yes to save the report, then click OK in the prompt message window.

 Task 8: Analyze data of a chart

Now let’s focus on the chart at the lower part of the Sales report tab. In JReport, a chart can be converted to a crosstab, and vice versa. So we will convert the chart to a crosstab first.

1. Right-click anywhere on the chart and select To Crosstab from the shortcut menu.

2. In the Display tab of the To Crosstab dialog, add Product Type to the Columns box, Sales Quarter to the Rows box, and Total Sales to the Summaries box, then click Next.

3. In the Style tab, set the crosstab style as ClassicBlue, and then click OK. The chart is successfully converted to a crosstab.
Now, we want to return the crosstab to a chart, and change the chart type to line chart.

4. Click the **Undo** button on the toolbar to cancel the operation of converting chart to crosstab.

5. Right-click anywhere on the chart, and on the shortcut menu, click **Chart Type > Line > Line 2-D**. The chart appears as follows:

Next, we will format the chart.

6. Right-click the platform of the chart and select **Format Chart** from the shortcut menu.

7. In the Chart Type tab of Chart Definition dialog, select **Bench** from the Chart Type box, and select the **Clustered Bench 2-D** thumbnail.

8. Click the **Display** tab, select **Sales Quarter** in the Category box and click to remove it, then expand the **Products** category in the Resources box and add **Product Type** to the Category box. Remove **Product Type** from the Series box and add **Sales Quarter** in the Orders Detail category to the box. Add **Total Sales** in the Orders Detail category to the Show Values box. Then click **OK**.
9. The chart now appears as follows:

![Chart Image]

10. Right-click the chart and select **Format Platform** on the shortcut menu.

11. In the Format Platform dialog, click the **Border** tab, set Border Type to **solid** and Color to **#0000FF**, then click the **Data** tab, set Sort Category to **descend** and Sort Series to **descend**. Click **OK** to confirm.
Finally the chart looks as follows:

Next, we want to apply a filter to the business view the chart uses to show the data of North America.

14. Right-click anywhere on the chart and click Query Filter on the shortcut menu.

15. In the Query Filter dialog, specify the filter condition as follows. Click OK to apply the changes.
We can find that the filter is then saved as a user defined filter in the business view.

The chart now becomes:

16. Click the Save button on the toolbar. In the Save Report Template dialog, click Yes to save the report, then click OK in the prompt message window.
Part III: Advanced Reporting

In this part, we will focus on some advanced reporting features of JReport: how to use JReport Designer to create data resources and use the resources to build reports and library components; how the resources are published to JReport Server and managed on the server, etc..

The reports we build in this part are related to a fictional, mid-size retail coffee chain named Jinfonet Gourmet Java. All documents needed to run the business and drive decision-making are reports generated by JReport.

The business questions that JReport reports can answer include:

- What were the Sales totals last month? Last year?
- Which regions had the highest sales? Which sales representative?
- Which product was the best selling last month? Last year?
- ......

Reports deliver real-time data

By integrating sophisticated reporting functionality in enterprise applications, organizations can
access, analyze and deliver real-time data as well as unlock critical business data hidden within applications.

The reports access the same data storage as the applications of Jinfonet Gourmet Java:

Data sources used in the tracks

JReport reports can pull data from any type of JDBC-accessible database, including Oracle, Sybase and Informix, or other data sources such as XML, SOAP web service and HIVE. The data store for Jinfonet Gourmet Java is an RDBMS and XML file. The applications of the company:
inventory management system, store operations, supply chain management and order tracking, access and update the data store.

Reports created in this track are based on the built-in HyperSonic DBMS database and XML data source. The table below shows the tables in the DBMS and XML data sources. The DBMS Name/XML Name is the name of the table as it is known in the DBMS or XML data itself; the Table Name is the table name that is shown in the JReport Designer:

<table>
<thead>
<tr>
<th>DBMS database</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>DBMS Name</td>
<td>Table Name</td>
<td>Table Description</td>
</tr>
<tr>
<td>ACCOUNTMANAGERS</td>
<td>Account</td>
<td>Jinfonet Gourmet</td>
</tr>
<tr>
<td></td>
<td>Managers</td>
<td>Coffee employees</td>
</tr>
<tr>
<td>CONTACTS</td>
<td>Contacts</td>
<td>Customer contact information</td>
</tr>
<tr>
<td>CUSTOMERS</td>
<td>Customers</td>
<td>Customer name, contact, and address</td>
</tr>
<tr>
<td>ORDERS</td>
<td>Orders</td>
<td>Customer orders</td>
</tr>
<tr>
<td>ORDERSDETAIL</td>
<td>Orders Detail</td>
<td>Orders line items</td>
</tr>
<tr>
<td>PRODUCTS</td>
<td>Products</td>
<td>Product information</td>
</tr>
<tr>
<td>STOCKMARKET</td>
<td>Stock Market</td>
<td>Stock information</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>XML data source</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>XML Name</td>
<td>Table Name</td>
<td>Table Description</td>
</tr>
</tbody>
</table>
By mapping the actual data source names to JReport Designer names, report designers can work with more intuitive or customized names.

This part contains the following tracks:

**Track 1: Creating Page Reports**

**Track 2: Creating Business Views**

**Track 3: Creating Web Reports**

**Track 4: Creating Library Components**
Track 5: Publishing, Running and Administering Resources

Track 6: Integrating Reports and Dashboards

Click the right arrow (→) below to begin reading the part.
Track 1: Creating Page Reports

A page report is a container which holds multiple report tabs. Report tabs in the same report can share the same parameters and dataset, and generally, have been designed for the same purpose, or related purposes. You can design, maintain and schedule them together. A page report file has a .cls extension.

In this track, assume that you are a report developer working for the Jinfonet Gourmet Java company. You have been asked to write a set of reports based on the data in the company's database. For a description of the tables in this database, see Data sources used in the tracks.

This track contains the following lessons:

- Lesson 1: Creating a Standard Banded Report
- Lesson 2: Creating a Horizontal Banded Report
- Lesson 3: Creating a Mailing Label Report
- Lesson 4: Creating a Chart Report
- Lesson 5: Creating a Table Report
- Lesson 6: Creating a Crosstab Report
Lesson 7: Creating a Tabular Report

Lesson 8: Creating a Report That Contains a Subreport

Lesson 9: Creating a Parameter-based Report

You will be developing a set of new page reports based on the procedures in this track. JReport provides finished versions of these reports if you would like to reference them. See the note at the end of each lesson for information about how to access the JReport-provided tutorial reports.

Click the right arrow () below to begin reading the track.
Lesson 1: Creating a Standard Banded Report

A report of monthly sales for the last two years has been requested by the Vice President of Sales at Jinfonet Gourmet Java. In this report, totals for sales need to be broken down by each order and each month, as well as presented for a grand total of all months.

Here’s a draft of the report the vice president has given to you:

<table>
<thead>
<tr>
<th>Year 1 Month 1</th>
<th>Order ID 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type ID</td>
<td>Product ID</td>
</tr>
<tr>
<td>1</td>
<td>11</td>
</tr>
<tr>
<td>2</td>
<td>12</td>
</tr>
<tr>
<td>3</td>
<td>13</td>
</tr>
</tbody>
</table>

Total sales by Order: xxxx

<table>
<thead>
<tr>
<th>Year 1 Month 1</th>
<th>Order ID 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type ID</td>
<td>Product ID</td>
</tr>
<tr>
<td>1</td>
<td>11</td>
</tr>
<tr>
<td>2</td>
<td>12</td>
</tr>
<tr>
<td>3</td>
<td>13</td>
</tr>
</tbody>
</table>

Total sales by Order: xxxx

Total sales by Month: xxxx

<table>
<thead>
<tr>
<th>Year 1 Month 2</th>
<th>Order ID 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type ID</td>
<td>Product ID</td>
</tr>
<tr>
<td>1</td>
<td>11</td>
</tr>
<tr>
<td>2</td>
<td>12</td>
</tr>
<tr>
<td>3</td>
<td>13</td>
</tr>
</tbody>
</table>

Total sales by Order: xxxx

Total sales by Month: xxxx

Grand Total: xxxx
You immediately recognize the repetitive, columnar data in the center of the report and associated subtotals as a candidate for a standard banded report. This type of report has horizontal “bands” or panels that are geared for either detailed record display or calculations, such as subtotals, that apply to a preceding group or the entire report.

Follow the tasks below to finish creating the report:

- **Task 1: Create the initial report and query to populate it**
- **Task 2: Add summaries and a print date to the report**
- **Task 3: Fine tune the report layout**

**Task 1: Create the initial report and query to populate it**

In this task, the report wizard collects the necessary information and then creates the standard banded report. The data resources such as query and formulas needed in the report can be created via the report wizard.

2. Click **File > Open Catalog**.
The Open Catalog File dialog appears.

3. Browse to select the JinfonetGourmetJava.cat catalog file in \<install_root>\Demo\Reports\JinfonetGourmetJava, click the Open button, and then click Yes in the Warning dialog.

The Catalog Manager appears for managing the selected catalog. Close it since we will not use it in the lesson.


5. In the Select Component for Page Report dialog, select Banded, then click OK.
6. In the Data screen of the Banded Wizard, click <New Query...> in the Queries node of Data Source 1, input **OrderListbyDate** in the Enter Query Name dialog and then click **OK**.
Queries are a higher-level object in a catalog. The concept is similar to that of views in the database but they are stored in the catalog file rather than the database itself. You can use queries to view, change and analyze data in different ways, and JReport can help you with the building of various professional reports based on queries.
7. In the Add Tables/Views/Queries dialog, expand the JDBC connection node and then the Tables node, then select the tables Orders, Orders Detail and Products and click \( \rightarrow \) to add them to the query. Click OK to close the dialog.

8. In the Query Editor, select all the columns in the three tables by selecting the * checkbox, then uncheck the Inventory and Reorder Level columns in the Products table. The selected columns will be added to the query and can be used for creating reports.
By default, the auto join options for queries are enabled (you can find the options on the sub menu of Query > Auto Join in the Query Editor), which means tables will be automatically joined in queries based on the join criteria. So, the three tables are automatically joined because JReport Designer recognizes
the matching rows in each table. You can modify the join if desired or customize a different join for set of tables.

JReport creates the SQL SELECT statement based on the columns, tables, and joins you specify. Click the SQL button to see the SQL SELECT statement if necessary.

9. Click OK at the bottom of the Query Editor to create the query.

10. Click Next in the Banded Wizard to show the Display screen. The Display screen determines which fields returned by the dataset are visible in the report.

11. From the Resources box, drag and drop the following fields in the Products table to the right-hand box one by one: Product Type Name, Products_Product ID, Product Name and Category, then change the display name of Products_Product ID to Product ID.
12. Click Next to display the Group screen. The Group screen specifies the grouping criteria to be applied to the selected records.

There are two levels of grouping in this report: first by Order Date and second by Orders_Order ID.
13. From the Resources box, select the fields **Order Date** and **Orders_Order ID** in the Orders table and click to add them as the group by fields one by one.

You can choose the sorting sequence of the groups in the Sort column. Specify it in descending order (c,b,a), ascending order (a,b,c) or a special ordering criteria. By default the order is Ascend.

14. Select **For each month** from the Special Function drop-down list for the Order Date group.
By selecting the for each month special function, the records, of which the field values are in the same month, will be grouped together.

15. Click Style to switch to the screen and select Simple from the Style list. The Summary, Chart, and Filter screens are skipped.

By default, when you create a banded, table, crosstab or chart report via the report wizard, a default style Basic will be applied to it. However, in this lesson, we want to customize the report style by ourselves, so here we select the Simple style which has very little formatting.

16. Click Finish to create the report.

The report with banded object is created. The panels in the banded object are identified on the left side by their abbreviations: a banded header panel (BH), a banded page header panel (BPH), a detail panel (DT), a banded page footer panel (BPF), a banded footer panel (BF), and two group header panels (GH) and group footer panels (GF) for the two levels of grouping:

17. Click the View tab to run the report and view it.
Task 2: Add summaries and a print date to the report

As it is described in the first paragraph of this lesson, you need to calculate the totals of sales per order and per month, and then the total of all months. These types of calculations can be accomplished by defining a dynamic summary that performs the computation and placing it in the group footer panel directly. A print date is a predefined field that is calculated at runtime by JReport.

First we need to add a field to the report that calculates the sales data. The predefined formula Total turns out to meet the requirement. The formula expression is as follows: @"Unit Price" * @Quantity - @"Unit Price" * @Quantity * @Discount/100.

1. From the Data panel, drag the **Total** formula in the Formulas node and drop it next to the Category DBField. The label of the formula is then placed in the second GH panel as follows:

The Data panel is an integrated interface for managing the resources that are used in the current report. You can create new resources including formulas, summaries and parameters to use in the report and they will be saved into the current catalog data source.

Next, we will create a dynamic summary based on the Total formula, so as to compute total of product sales by order, by month and also to calculate the grand total.

2. In the Data panel, select `<New Summary...>` in the Summaries node.

3. In the New Summary dialog, choose **Sum** from the Aggregate Function drop-down list, select the **Total** formula in the Formulas node of the Resource...
box and click to add it to the Summary On field, check the Dynamic Summary radio button and keep its default settings, then click OK.

4. Input `Sum_ProductSales_DynamicSummary` in the Enter Summary Name dialog and click OK to create the summary.

Then when we insert this summary into the groups. JReport will do the calculation based on the groups. If the summary is inserted into the banded header or banded footer panel, it will compute based on the whole banded report.

5. Drag the summary `Sum_ProductSales_DynamicSummary` from the Summaries node of the Data panel to both of the two GF panels as well as the BF panel.

6. Double-click the label for each of the newly added summaries to edit the text to Total by Order, Total by Month and Grand Total respectively.
7. Resize the BPH panel and drag a label from the Basic group in the Components panel to add a label in it.

8. Resize the newly-added label and double-click it to edit its text to **Order List by Date**.

9. Click **Insert > Special Fields > Date-time > Print Date** and then place the special field in the BPH panel, next to the Order List by Date label.

10. Insert the Print Time special field in the same way.

11. Double-click the **Print Date** and **Print Time** labels and edit their text to **Date** and **Time**, respectively.

12. Adjust the position of the two groups by fields, add two labels ahead of them for identification and edit their text as **Order Date** and **Order ID** as
Task 3: Fine tune the report layout

To make the report easier to read, we need to make some adjustments to the report layout.

1. Resize the second GH panel. Select the Product Type Name, Product ID, Product Name and Category name labels in the BPH panel by holding the Ctrl key on the keyboard and move them to the second GH panel, so that they can be closer to the actual data they describe.

2. Resize the Product Type Name, Product ID, Product Name, Category and Total name labels, as well as their corresponding DBFields, manually drag and align them as follows:

3. Select the Product ID name label and the corresponding DBField in the DT panel by holding the Ctrl key on the keyboard, then click Format > Left to change their alignment so as to improve the report layout.

4. Select the five labels Product Type Name, Product ID, Product Name, Category and Total by holding the Ctrl key on the keyboard, then in the
Report Inspector, set their properties Background and Foreground to **Lightgray** and **White**.

5. Select the **Total by Order** and **Total by Month** summaries as well as their name labels by holding the Ctrl key on the keyboard, then change their Foreground property to **Gray** in the Report Inspector.

6. Select the **Grand Total** summary and its name label in the BF panel by holding the Ctrl key on the keyboard, then change the Foreground property to **Red** in the Report Inspector.
7. Select the **Order ID** group by field and its name label in the second GH panel by holding the Ctrl key on the keyboard and change their Foreground property to **Red** in the Report Inspector.

8. Select the **Date** and **Time** special fields in the BPH panel and the **Order Date** group by field in the first GH panel with their name labels by holding the Ctrl key on the keyboard, then change their Foreground property to **Gray** in the Report Inspector.

9. Resize the **Order List by Date** label, change its Font Size property to **18**, and Foreground property to **Red** in the Report Inspector.

10. Resize the **Date** and **Time** special fields and their name labels and change their position in the BPH panel to make them look tidy in the report.

11. In the Report Inspector, select the nodes representing the two group footer panels and the banded footer panel by holding the Ctrl key on the keyboard, then set their Background property to **Transparent**.

12. Right-click in the BH panel and select **Hide** from the shortcut menu to hide it from view. Repeat to hide the BPF panel in the same way.

After editing, the report looks somewhat like below in design view:
Next, we will give the report tab a meaningful name and save the report.

14. On the report tab bar, right-click the report tab and select Rename from the shortcut menu.

15. In the Input Report Tab Name dialog, enter OrderDetails and click OK.

16. Click File > Save to save the report as OrderListbyDate.cls.

17. Click the View tab to run the report and view it. The report should look similar to the following one:
Order List by Date

Order Date  1/2015
Order ID  3003

<table>
<thead>
<tr>
<th>Product Type Name</th>
<th>Product ID</th>
<th>Product Name</th>
<th>Category</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decaf</td>
<td>12</td>
<td>House Blend</td>
<td>Bold</td>
<td>5,094.40</td>
</tr>
<tr>
<td>Decaf</td>
<td>17</td>
<td>Java Dragon Blend</td>
<td>Mild</td>
<td>9,226.70</td>
</tr>
<tr>
<td>Regular</td>
<td>21</td>
<td>Kenya Peabody</td>
<td>Exotic</td>
<td>3,356.88</td>
</tr>
<tr>
<td>Decaf</td>
<td>27</td>
<td>Kona Mountain</td>
<td>Blends</td>
<td>13,376.00</td>
</tr>
</tbody>
</table>

Total by Order  31,053.98

Order ID  3004

<table>
<thead>
<tr>
<th>Product Type Name</th>
<th>Product ID</th>
<th>Product Name</th>
<th>Category</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decaf</td>
<td>4</td>
<td>Organic Espresso Decaf</td>
<td>Espresso</td>
<td>4,113.12</td>
</tr>
<tr>
<td>Regular</td>
<td>29</td>
<td>Colombia El Tambo</td>
<td>Blends</td>
<td>7,092.00</td>
</tr>
<tr>
<td>Decaf</td>
<td>31</td>
<td>Gold Coast Blend</td>
<td>Blends</td>
<td>9,766.85</td>
</tr>
</tbody>
</table>

Total by Order  20,971.97

Order ID  3005

<table>
<thead>
<tr>
<th>Product Type Name</th>
<th>Product ID</th>
<th>Product Name</th>
<th>Category</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Regular</td>
<td>1</td>
<td>Espresso Roast</td>
<td>Espresso</td>
<td>1,683.99</td>
</tr>
</tbody>
</table>

Note: If the report does not look correct, you can compare it to the final version of the report provided by JReport. To do so, you will need to save and close this catalog and then open the JinfonetGourmetJava.cat catalog file located at <install_root>\Demo\Reports\TutorialReports.
Lesson 2: Creating a Horizontal Banded Report

Your new reporting assignment is to create a summary of each Jinfonet Gourmet Java employee. The report will also need to communicate the ranking of the employee's salary, that is, whether it is on the upper or lower end, or somewhere in between, relative to all employees. The following prototype of the report has been given to you:

Follow the tasks below to finish creating the report:

**Task 1: Create the initial report**

**Task 2: Adjust the layout of the report and add the Photo DBField**

**Task 3: Rank the employees**

**Task 4: Fine tune the report layout**

**Task 1: Create the initial report**

Again the report has repeated rows of information, but this time they are repeated left to right instead of top down. A horizontal banded report is offered to support this format.

To create the initial report with a horizontal banded object, follow these steps:

1. In JReport Designer click **File > New > Page Report**.

2. In the Select Component for Page Report dialog, select **Horizontal Banded**, then click **OK**.

   Be sure that JinfonetGourmetJava.cat is specified as the current catalog because it is the catalog we use in this track. For information about specifying this catalog, see **Task 1, Step 2 and 3** of Lesson 1.
3. In the Data screen of the Horizontal Banded Wizard, click `<New Query...>` in the Queries node of Data Source 1, input `EmployeeInformation` in the Enter Query Name dialog and click OK.

4. In the Add Tables/Views/Queries dialog, expand the JDBC connection node and then the Tables node, then select the table `Account Managers` and click to add it to the query. Click OK to close the dialog.

5. In the Query Editor, select `*` in the Account Managers table to add all the columns in it to the query and then click OK at the bottom of the editor to create the query.

6. Click Next in the Horizontal Banded Wizard to go to the Display screen.

7. From the Resources box, select the following DBFields in the Account Managers table and click to add them to the right-hand box one by one: Name, Employee Position, Notes, HireDate, Birthday and Home Phone, edit the display names HireDate and Birthday to Hire Date and Birth Date, then click Next.

8. In the Group screen, select Account Manager ID and click to add it as the group by field.
9. Click **Style** to switch to the screen and select **Simple** as the report style. Click **Finish** to create the report and the report appears as follows:

The panels in the banded object are identified on the top by their abbreviations: a banded header panel (BH), a banded page header panel (BPH), a group header panel (GH), a detail panel (DT), a group footer panel (GF), a banded page footer panel (BPF) and a banded footer panel (BF).

**Task 2: Adjust the layout of the report and add the Photo DBField**

To improve the appearance of the report, we will do some adjustments to the report's layout. In addition, we will add a Photo field to the report which allows the report to be used to identify the employee.

1. Widen the DT panel, then resize the **Employee Position** and **Notes** DBFields horizontally so that the data won't get truncated.

2. Select the **Name**, **Employee Position** and **Notes** labels in the BPH panel by holding the Ctrl key on the keyboard and press the **Delete** button on the keyboard to remove them from the report.
3. Adjust the space between fields in the DT panel, move the Hire Date, Birth Date, and Home Phone name labels from the BPH panel to the DT panel and place them above their fields as follows:

4. Hide the BH, BPH, GF, BPF and BF panels that don’t hold any data by right-clicking the panel and select Hide from the shortcut menu.

5. Resize the GH panel, click Insert > Label to add a label before the group field in the panel, edit its text as "Employee ID:”, resize the group field and the label, and adjust the position like the following:

6. From the Data panel, drag the Photo DBField in the Account Managers table to the GH panel.
7. Remove the name label of the Photo DBField by right-clicking it and selecting **Delete** from the shortcut menu, then resize the field as follows:

![Diagram showing resized field](image)

8. Click **Insert > Drawing Object > Line** to insert a line object below the first field in the DT panel, and insert a box object in the same way to enclose all the objects in the reports.

![Diagram with line and box objects](image)
Task 3: Rank the employees

As required at the beginning of the report design, the manager wants to rank the employees by their salaries, so we will add a rank object to the report.

1. Select the DT panel of the report and click Insert > Rank to display the Rank Expert dialog.

2. In the Rank Expert dialog, first select Salary from the Rank Resources box.

3. Click the Browse button, choose Rank5.gif in the JinfonetGourmetJava folder and click Open to select it as the default image for all value ranges.

4. In the Value Range box, input 40000 in the Minimum cell, 49999 in the Maximum cell, then click in the Image cell and click Browse... to choose Rank3.gif as the image of this range.

5. Click + twice to add two ranges and define them as follows:

6. Click the Insert button to insert the rank to the DT panel, below the Home Phone field.

7. Move the name label Salary of the rank from the bottom of GH panel and place it above the rank, then edit its text to Salary Ranking and resize the label to full display the text.
Task 4: Fine tune the report layout

1. Select the **Employee ID** label and the group by field in the GH panel by holding the Ctrl key on the keyboard, then select 10 from the Font Size drop-down list on the toolbar.

2. Hold the Ctrl key on the keyboard and select the **Salary Ranking** label and the rank in the DT panel, then click the **Left** button on the toolbar so as to make them aligned the same with other objects in the DT panel.

3. Select the first field in the DT panel (the Name DBField), change its properties in the Report Inspector as follows, then resize it to make sure the names can be fully displayed.
   - Font Size: 12
   - Bold: true
   - Foreground: 0xcc0000

4. Right-click the **Photo** DBField in the GH panel and select **Display Type** from the shortcut menu.

5. In the Display Type dialog, select **Image** in the Display As box, choose **GIF** or **JPG** from the Decode Type drop-down list, then click **OK**.

![Diagram of report layout](image.png)
6. In the Report Inspector, select the Line node in the report structure tree and change its Line Color property to Lightgray, Line Thickness to 0.02.

7. Select the Box node and change its Border Color property to Lightgray too.

Next, we will add a title to the report to the page header panel of the report.
8. Click View > Page Header to display the page header.

9. In the Report Inspector, select the Page Header Panel node and change its Height property to 0.6.

10. Drag the label object from the Components panel and drop it in the page header panel.

11. Resize the label, double-click it to modify its text as Employee Information List, then in the Report Inspector, change its Font Face property to Arial, Font Size to 14, and Foreground to 0xcc0000.

After editing, the report looks somewhat like below in design view:

![Design View of Employee Information List Report](image)

12. On the report tab bar, right-click the report tab and select Rename to rename it to EmployeeDetails.

13. Click File > Save to save the report as EmployeeInformation.cls.
14. Click the View tab to preview the report. The report appears similar to the below one:

![Employee Information List](image)

<table>
<thead>
<tr>
<th>Employee ID: 1</th>
<th>Employee ID: 2</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Lauren Croft</strong></td>
<td><strong>Jonathan Hopkins</strong></td>
</tr>
<tr>
<td>Sales Representative</td>
<td>Sales Representative</td>
</tr>
<tr>
<td><a href="mailto:l.croft@sales.gourmetjava.com">l.croft@sales.gourmetjava.com</a></td>
<td><a href="mailto:j.hopkins@sales.gourmetjava.com">j.hopkins@sales.gourmetjava.com</a></td>
</tr>
<tr>
<td>Hire Date</td>
<td>Hire Date</td>
</tr>
<tr>
<td>Birth Date</td>
<td>Birth Date</td>
</tr>
<tr>
<td>Home Phone</td>
<td>Home Phone</td>
</tr>
<tr>
<td>(301) 555-7424</td>
<td>(301) 555-2349</td>
</tr>
<tr>
<td>Salary Ranking</td>
<td>Salary Ranking</td>
</tr>
<tr>
<td>⭐⭐⭐⭐⭐</td>
<td>⭐⭐⭐⭐</td>
</tr>
</tbody>
</table>

**Note:** If the report does not look correct, you can compare it to the final version of the report provided by JReport. To do so, you will need to save and close this catalog and then open the JinfonetGourmetJava.cat catalog file located at `<install_root>` \Demo\Reports\TutorialReports.
Lesson 3: Creating a Mailing Label Report

In this lesson, we develop a Customer Contact Card report using the mailing label layout. This report can be used to print rolodex cards as well as mailing labels. On each card, the following information needs to be shown:

<table>
<thead>
<tr>
<th>Customer Name</th>
<th>Position</th>
</tr>
</thead>
<tbody>
<tr>
<td>Company Name</td>
<td></td>
</tr>
<tr>
<td>Country</td>
<td></td>
</tr>
<tr>
<td>Phone:</td>
<td>Fax:</td>
</tr>
</tbody>
</table>

The data source for this report is our built-in XML data, predefined as Data Source 2 in the catalog.

Follow the tasks below to finish creating the report:

- **Task 1: Define the query that the report uses**
- **Task 2: Add objects to the report**
- **Task 3: Edit object properties and print the report**

**Task 1: Define the query that the report uses**

1. In JReport Designer click **File > New > Page Report**.

2. In the Select Component for Page Report dialog, select **Mailing Label**, then click **OK**.
Be sure that JinfonetGourmetJava.cat is specified as the current catalog because it is the catalog we use in this track. For information about specifying this catalog, see Task 1, Step 2 and 3 of Lesson 1.

3. In the Data screen of the Mailing Label Wizard, click <New Query...> in the Queries node of Data Source 2, input **CustomerContactCard** in the Enter Query Name dialog and then click **OK**.
4. In the Add Tables/Views/Queries dialog, expand the XML connection node and then the **Tables** node, then select the table **Customer** and click to add it to the query. Click **OK** to close the dialog.

5. In the Query Editor, select all columns in the Customer table by choosing *, then uncheck the **NodePrimaryKey** and **NodeForeignKey** columns.
6. Click **OK** at the bottom of the Query Editor to create the query.

7. Click **Style** to switch to the screen in the Mailing Label Wizard and select **Simple** as the report style, then click **Finish** to create the report.

The report with an empty banded object is created. The panels in the banded object are identified on the left side by their abbreviations: a banded header panel (BH), a banded page header panel (BPH), a detail panel (DT), a banded page footer panel (BPF) and a banded footer panel (BF).

**Task 2: Add objects to the report**

1. Select and resize the DT panel of the banded object, to make it similar to the one below:
We will use a simple formula to create a single value out of the customer’s last and first names, and similarly to the address.

2. In the Data panel, select `<New Formula...>` in the Formulas node.

3. Input the formula name `CustomerContactName` in the Enter Formula Name dialog, click OK, define the formula in the Formula Editor as

   `@ContactFirstName + " " + @ContactLastName` (you can copy the formula to the formula editing area directly), click Save on toolbar, then close the editor.
4. Create another formula named **CustomerContactAddress** using the same way and define it as follows:

   @Address1 + ", " + @City + ", " + @State + " " + @PostalCode

Now we will use one of the JReport Designer’s customizations that can simplify the creation of this report.

5. Click **File > Options**.

6. In the Options dialog, select **Component**, remove the checkmark from the **Insert field name label with field** checkbox and click **OK**.

We don't want to show the name labels of the DBFields in this report. Now we can add our formulas and DBFields to the report.

7. From the Data panel, drag the **CustomerContactName** formula in the Formulas node to the DT panel of the banded object, and then the
ContactPosition DBField in the Customer table to the right of it.

8. Use the same way to add the following fields:

9. Add two labels ahead of the Phone and Fax DBFields to identify them by dragging from the Basic group in the Components panel. Resize the labels and edit their text to "Phone:" and "Fax:" respectively, select the two labels by holding the Ctrl key on the keyboard and change their Bold property to false in the Report Inspector, then the report displays as follows.
10. Insert a Line drawing object just above the CustomerName DBField by clicking Insert > Drawing Objects > Line.

11. Select the DT panel of the banded object and add a Box drawing object to enclose all the objects in the panel by clicking Insert > Drawing Objects > Box.
12. Resize the BPH panel, drag from the Basic group in the Components panel to add a label in it, then resize the label and edit its text to **Customer Contact Card** as the title of the report.

**Task 3: Edit object properties and print the report**

1. Select the label in the BPH panel and change its properties in the Report Inspector as follows:
   - Bold: false
   - Font Size: 14
   - Foreground: Red

2. Select all the objects in the DT panel except the Line and the Box drawing objects by holding the Ctrl key on the keyboard, then select 10 from the
font size drop-down list 9 on the Format tab.

3. Select the CustomerContactName formula and click Format > Bold B.

4. In the Report Inspector, select the Box node from the report structure tree and change its Border Color property to Lightgray.

5. Select the Line node and edit its Line Color property to Lightgray and Line Thickness to 0.02.

6. Resize the fields horizontally if data is truncated.
7. Hide the BH, BPF and BF panels that don't hold any data by right-clicking the panel and select **Hide** from the shortcut menu.

8. On the report tab bar, right-click the report tab and select **Rename** to rename it to **CustomerInformation**.

9. Click **File > Save** to save the report as **CustomerContactCard.cls**.

10. Click the **View** tab to preview the report. The report appears similar as follows:
The report displays as expected. We can print it to make the customer contact card now.
11. Click **File > Print** and then specify the settings in the Print dialog according to your requirements.

12. Click **File > Options** again to enable the **Insert field name label with field** option in the Component category, so that later when you add fields to reports, their name labels can be added automatically.

**Note:** If the report does not look correct, you can compare it to the final version of the report provided by JReport. To do so, you will need to save and close this catalog and then open the JinfonetGourmetJava.cat catalog file located at `<install_root>\Demo\Reports\TutorialReports`. 
Lesson 4: Creating a Chart Report

The fourth quarter of the year has just ended, and you have been asked to produce a chart that shows product annual sales for each sales region. The sales manager wants to compare the historical sales data with the current data. Here's a sketch of the report that the sales manager has given to you, a bar chart:

JReport supports more than 10 general chart types, and most of them have many sub-types or variations. After showing the sales manager the available bar chart types, he chose the 2-dimensional clustered bar chart.

Additionally, the sales manager requests that the report should be provided in Microsoft Excel file. This is not a problem, because all pre-defined reports in JReport can be exported to HTML, PDF, Excel, RTF, XML, Text, Postscript, Mail and Fax.

Follow the tasks below to finish creating the report:

Task 1: Create the chart

Task 2: Format the chart

Task 3: Export the report to an Excel file
Task 1: Create the chart

1. In JReport Designer click **File > New > Page Report**.

2. In the Select Component for Page Report dialog, keep the default selected component type Chart and click **OK**.

   Be sure that JinfonetGourmetJava.cat is specified as the current catalog because it is the catalog we use in this track. For information about specifying this catalog, see **Task 1, Step 2 and 3** of Lesson 1.

3. In the Data screen of the Chart Wizard, select the query **AnnualSalesbyRegion** from the Queries node of Data Source 1 and then click **Next**.

4. In the Type screen, keep the default chart type Clustered Bar 2-D, then click **Next**.

   In this chart, we want to display the region name on the category (X) axis, and annual sales of each region on the value (Y) axis. However, as the region names are too long to be displayed completely on the category axis, we will create a formula here to just get the abbreviations of the region names.

5. In the Display screen, scroll down to the **Formulas** node in the Resources box, and then click **<New Formula...>**.

6. Input the formula name **Region_AbbreviationName** in the Enter Formula Name dialog and click **OK**, then define the formula in the Formula Editor as follows (you can copy the formula to the formula editing area directly), click **Save** on the toolbar to save the formula, and close the editor.

   ```java
   if (@Customers_REGION == "Asia-Pacific")
       "APAC"
   else if (@Customers_REGION == "Europe, Middle East, Africa")
       "EMEA"
   else if (@Customers_REGION == "Latin America")
       "LATAM"
   else if (@Customers_REGION == "North America")
       "NA"
   ```

7. Add the formula **Region_AbbreviationName** to the Category box and **YearofOrderDate** to the Series box one by one by selecting each and clicking ➔ beside the corresponding box. In the Show Values box, a numerical value is required.
In this lesson, we need to show the annual sales of each region, so a summary which is created on the column Annual Sales, and grouped by the formula Region_AbbreviationName is needed.

8. Click <New Summary…> under the Summaries node in the Resources box of the Display screen.

9. In the New Summary dialog, specify the aggregate function as Sum, add the field Annual Sales from the Customers table to the Summary On field, specify the Group By field as the Region_AbbreviationName formula, then click OK.

![New Summary dialog](image)

10. Input Sum_AnnualSalesbyRegion_AbbreviationName in the Enter Summary Name dialog and click OK to create the summary.

11. Select the newly-created summary and click beside the Show Values box. The Display screen appears as follows:
Next we will use the Layout screen of the Chart Wizard to add titles to the chart. The Layout screen provides options for customizing the layout of a chart, for example, you can hide some chart elements such as the legend and wall, set the offset of the category and series axes and so on.

12. Click **Layout** to switch to the screen, select **Title** from the Options box, and then enter **Annual Sales by Region** in the Chart Title text box and **Regions** in Category (X) Axis Title.
JReport provides a set of CSS styles that can be applied to reports to easily change the format and appearance of the report. We will apply the Classic style to the chart.

13. Click Next to go to the Style screen and select Classic from the style list.

14. Click Finish to create the chart report and the report shows as follows in the design view:
Task 2: Format the chart

The chart is accurate, but a little simple. We can add some polish to it by setting some of the chart properties. For each part of the chart object, such as the axes, legend, wall and so on, JReport provides a corresponding format dialog, with which we can easily edit properties of a chart.

1. Click the Design tab to return to the design mode to do the adjustments.
2. Double-click a bar of the chart, and the Format Bar dialog appears.

3. In the General tab of the dialog, set the **Use Depth** option to **true**. Keep the default Depth and Direction.

   In the Format Bar dialog, you could also choose another sub-type for the chart in the Layout box if desired. In this lesson, we will continue using Clustered - 2D.

4. Switch to the **Data Label** tab, specify Font as **Arial** and Font Size to **10 pt**.

   The Data labels that charts contain can be either static or dynamic. You can check the Show Static Data Label option and specify the Position for data labels according to your requirements, so that the labels are displayed statically in the chart. But in this lesson, we will just use the labels as dynamic ones, which will appear when the cursor is placed on bars.

5. Click **OK** to apply these property settings to bars of the chart.

6. Right-click the legend and then select **Format Legend** from the shortcut menu.
7. In the Format Legend dialog, click the **Font** tab, set Font as **Arial** and Font Size to **10 pt**.

8. Switch to the **Mark** tab, keep Item 0 selected in the Mark Items box, and select **circle** from the mark drop-down list.

9. Select **Item 1** in the Mark Items box, and apply **upward triangle** to it in the same way.

10. Click **OK** in the Format Legend dialog to apply these changes.

11. Right-click the chart and then select **Format Axes > Format Value (Y) Axis** from the shortcut menu.

12. In the Format tab of the Format Value (Y) Axis dialog, select `$#,##0` in the Number category, and then click **Add**.
13. Click OK in the Format Value (Y) Axis dialog.

14. Double-click the Regions label. In the Format Label dialog, switch to the Font tab, specify Font as Arial and Font Size to 10 pt, and then click OK.

15. On the report tab bar, right-click the report tab and select Rename to rename it to AnnualSales.

16. Click File > Save to save the report as AnnualSalesbyRegion.cls.
17. Click the View tab to preview the report and it looks somewhat as follows. We can easily compare the sales per region over a two-year period.

Note: If the report does not look correct, you can compare it to the final version of the report provided by JReport. To do so, you will need to save and close this catalog and then open the JinfonetGourmetJava.cat catalog file located at <install_root>\Demo\Reports\TutorialReports.

Task 3: Export the report to an Excel file

Now we can export the report to different formats as required. The sales manager requires an Excel file for the report so we will export it to the Excel format.

1. Click File > Export > Excel.

2. In the Export to Excel dialog, keep the default settings and click OK.
3. Open the file `AnnualSalesbyRegion_AnnualSales.xls` saved in `<install_root>\Demo\Reports\JinfonetGourmetJava`. It appears as follows:
Lesson 5: Creating a Table Report

The Jinfonet Gourmet Java company receives orders from customers in different territories around the world, and by reviewing this shipping information the Shipping Department can receive bids from various shipping vendors. You are assigned the task of creating a shipment information report. In the report, the shipment details, including order ID, order date, ship date, shipping cost, whether the payment has been received, and the shipping vendor, need to be reported for each territory.

The following prototype of the report has been given to you:

<table>
<thead>
<tr>
<th>Order ID</th>
<th>Order Date</th>
<th>Ship Date</th>
<th>Ship Via</th>
<th>Payment Received</th>
<th>Shipping Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Territory</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Customer Name</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>XXXX</td>
<td>XXXX</td>
<td>XXXX</td>
<td>XXXX</td>
<td>Yes/No</td>
<td>XXXX</td>
</tr>
<tr>
<td>XXXX</td>
<td>XXXX</td>
<td>XXXX</td>
<td>XXXX</td>
<td>Yes/No</td>
<td>XXXX</td>
</tr>
<tr>
<td>XXXX</td>
<td>XXXX</td>
<td>XXXX</td>
<td>XXXX</td>
<td>Yes/No</td>
<td>XXXX</td>
</tr>
</tbody>
</table>

| Customer Name |
| XXXX | XXXX | XXXX | XXXX | Yes/No | XXXX |
| XXXX | XXXX | XXXX | XXXX | Yes/No | XXXX |
| XXXX | XXXX | XXXX | XXXX | Yes/No | XXXX |

| Territory |
| Customer Name |
| XXXX | XXXX | XXXX | XXXX | Yes/No | XXXX |
| XXXX | XXXX | XXXX | XXXX | Yes/No | XXXX |
| XXXX | XXXX | XXXX | XXXX | Yes/No | XXXX |

This report will be run online by employees in the Shipping Department. The interactive functionalities of JReport page reports allow end users to change the view of the reports, filter the data, change the sort order, search the report and so on. Each end user can get the data he needs from a single report.

Follow the tasks below to finish creating the report:

Task 1: Create the table

Task 2: Add a web control to the report

Task 3: Add objects and edit their properties

Task 1: Create the report
Before taking this task, make sure you have enabled the Insert field name label with field option in the Options dialog as described at the last step of Lesson 3. Otherwise, the name labels will not be inserted together with the fields when you add fields to the table.


2. In the Select Component for Page Report dialog, select Table (Group Above) and click OK.

Be sure that JinfonetGourmetJava.cat is specified as the current catalog because it is the catalog we use in this track. For information about specifying this catalog, see Task 1, Step 2 and 3 of Lesson 1.

3. In the Data screen of the Table Wizard, click <New Query…> in the Queries node of Data Source 1, input ShipmentDetailsbyCustomer in the Enter Query Name dialog and click OK.

4. In the Add Tables/Views/Queries dialog, expand the JDBC connection node and then the Tables node, then select the tables Customers and Orders and click to add them to the query. Click OK to close the dialog.

5. In the Query Editor, the two tables are joined together automatically on the Customers_Customer ID and CustomerID_FK1 columns.
6. Check all the columns in the Orders table by selecting the * checkbox. For the Customers table, check the following columns: Customer Name, Customers_State, Customers_Country, Customers_Territory and CustomersRegion.

7. Click OK at the bottom of the Query Editor to create the query. Then click Next in the Table Wizard.

8. In the Display screen, add the fields Orders_Order ID, Order Date, Ship Date, Ship Via, Payment Received and Shipping Cost to the table by selecting them and clicking one by one.

By default, the records in a table are displayed randomly; they are displayed in the order they are returned from the fetch operation. You can specify that JReport sort the records in a table, and also within the groups in table if any, according to your requirement. In this lesson, we will make the records in the table sorted by order ID ascendingly.

9. Click the Sort Fields By button at the right bottom corner of the Display screen. In the Sort Fields By dialog, select Orders_Order ID in the Resources box and click to add it as the sort by field, then click OK to return back to the table wizard.

10. Click Next in the Table Wizard to display the Group screen.
Since the report is required to display shipment details of each customer in specific territory, we will add two groups to it: first group the report by territory and then by customer name.

11. In the Group screen, add the DBFields **Customers_Territory** as the first group by field and **Customer Name** the second one.

12. Click **Style** to switch to the screen and select to display the report in the **Classic** style vertically.

13. Click **Finish** to create the report.

14. Click the **View** tab to preview the report and it appears as follows:
The required report has been created, but it is cumbersome to locate the shipment details of specific territories. So our next task is to add web controls to the report so that the end user can easily filter the results of the report.

**Task 2: Add a web control to the report**

Web controls empower end users of interactive reports to easily modify the report results they are viewing, and are defined by a trigger event, such as click, and a resulting web action.

In this task, we add a Drop-down List web control to the page header panel of the report. It will be used to filter the report records by territory.

1. Click **View > Page Header** to display the page header panel.

2. In the Report Inspector, select the **Page Header Panel** node and change its Height property to 1.25.
3. Click **Insert > Web Controls > Drop-down List** to insert a web control into the panel.

4. Right-click the web control and select **Display Type** from the shortcut menu.

5. In the Display Type dialog, click the **Value** cell and then click \( \ldots \) in it to display the Insert Fields dialog.

6. Select **Customers_Territory** in the Customers table in the DBField List box and click the **Insert** button to add it as value of the drop-down list.

7. In the Web Behaviors box, click the **Events** cell and select **Data Change** from the drop-down list, then click \( \ldots \) in the Actions cell.

![Display Type dialog](image)

8. In the Web Action List dialog, select the *Filter* action and click **OK**.

9. In the Filter - Web Action Builder dialog, specify to apply the action to **TableComp**, click the **Filter On** cell and select **Customers_Territory** from the drop-down list, then click the **Value** cell and select **MultiValueContainer**. Click **OK** to apply the settings.
10. Click **OK** in the Display Type dialog to confirm the settings.

11. Resize the drop-down list horizontally to make sure the territory name can be displayed completely.

**Task 3: Add objects and edit their properties**

In this task we will add more labels in the report, one as the report title and the other for data identification. We will also edit the properties of some objects to improve the report appearance.

1. Drag and drop two **label** objects from the Components panel to the page header panel. Resize them and edit their text as follows:

   ![Shipment Details by Customer]

   ![Territory]

2. Select the two labels by holding the Ctrl key on the keyboard and click the **Bold** button on the toolbar.

3. Resize the **Shipment Details by Customer** label, set its Font Size property to **18** and Foreground property to **Red** in the Report Inspector.
4. Select the **Order Date** and the **Ship Date** DBFields by holding the Ctrl key on the keyboard and set their Format property to *M/d/yyyy* in the Report Inspector.

5. Resize the group by fields in the two GH rows, add two labels ahead of them and edit the text of the labels as "**Territory:**" for the first group by field and "**Customer Name:**" for the second.

6. Select the four objects in the two group header rows by holding the Ctrl key on the keyboard, set their Foreground property to 0xcc0000.

7. Double-click the **Orders_Order ID** label in the TH row and edit its text to **Order ID**.

8. Select the **Ship Via** DBField and resize it to make sure no data get truncated. Do the same to the Payment Received label.

Next, we will apply a different background color to the two group header rows and hide the second group footer row to improve the appearance and layout of the report.

9. In the Report Inspector, select the **Table Group Header** and **Table Group Header 1** nodes from the report structure tree by holding the Ctrl key on the keyboard and set their Background property to 0xf3f3f3.
10. Right-click on the second GF row and select Hide from the shortcut menu to hide it.

11. On the report tab bar, right-click the report tab and select Rename to rename it to ShipmentDetails.

12. Click File > Save to save the report as ShipmentDetailsbyCustomer.cls.

13. Click the View tab to preview the report and it appears as follows:
Shipment Details by Customer

<table>
<thead>
<tr>
<th>Territory:</th>
<th>Customer Name:</th>
<th>Order ID</th>
<th>Order Date</th>
<th>Ship Date</th>
<th>Ship Via</th>
<th>Payment Received</th>
<th>Shipping Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Africa</td>
<td>Java Blend</td>
<td>3007</td>
<td>1/1/2015</td>
<td>1/3/2015</td>
<td>United Packing</td>
<td>True</td>
<td>100.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3366</td>
<td>9/2/2016</td>
<td>9/3/2016</td>
<td>Federal Shipping</td>
<td>True</td>
<td>100.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3382</td>
<td>10/4/2015</td>
<td>10/5/2016</td>
<td>Federal Shipping</td>
<td>False</td>
<td>100.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3400</td>
<td>11/2/2016</td>
<td>11/3/2016</td>
<td>Federal Shipping</td>
<td>False</td>
<td>100.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3417</td>
<td>12/4/2016</td>
<td>12/5/2016</td>
<td>Federal Shipping</td>
<td>True</td>
<td>100.00</td>
</tr>
<tr>
<td>Asia</td>
<td>The Java Roaster</td>
<td>3298</td>
<td>5/20/2016</td>
<td>5/21/2016</td>
<td>Express Delivery</td>
<td>True</td>
<td>150.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3315</td>
<td>6/6/2016</td>
<td>6/7/2016</td>
<td>Express Delivery</td>
<td>False</td>
<td>200.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3333</td>
<td>7/8/2016</td>
<td>7/9/2016</td>
<td>Express Delivery</td>
<td>True</td>
<td>150.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3350</td>
<td>8/6/2016</td>
<td>8/7/2016</td>
<td>Express Delivery</td>
<td>True</td>
<td>200.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3368</td>
<td>9/8/2016</td>
<td>9/9/2016</td>
<td>Express Delivery</td>
<td>False</td>
<td>150.00</td>
</tr>
</tbody>
</table>

Note: If the report does not look correct, you can compare it to the final version of the report provided by JReport. To do so, you will need to save and close this catalog and then open the JinfonetGourmetJava.cat catalog file located at `<install_root>`\Demo\Reports\TutorialReports.

The web controls are powered by Page Report Studio and therefore cannot work in JReport Designer. We can use the Preview as Page Report Result command of JReport Designer to preview this report, however this command is enabled only if the option Server for Previewing Reports was specified when installing JReport Designer.

Click View > Preview As > Page Report Result. The report is then opened in Page Report Studio in the default web browser.

Now we can select values from the drop-down list to dynamically change the report results. In the report below, we choose to view records in the Mexico territory.
You can go to Creating and Performing Data Analysis on Page Reports in the Quick Start part to get more details about working with Page Report Studio.

### Shipment Details by Customer

**Territory:** Mexico

<table>
<thead>
<tr>
<th>Order ID</th>
<th>Order Date</th>
<th>Ship Date</th>
<th>Ship Via</th>
<th>Payment Received</th>
<th>Shipping Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>3286</td>
<td>4/9/2016</td>
<td>4/10/2016</td>
<td>Parcel Flyers</td>
<td>True</td>
<td>150.00</td>
</tr>
<tr>
<td>3302</td>
<td>5/23/2016</td>
<td>5/24/2016</td>
<td>Express Delivery</td>
<td>True</td>
<td>100.00</td>
</tr>
<tr>
<td>3321</td>
<td>6/9/2016</td>
<td>6/10/2016</td>
<td>Parcel Flyers</td>
<td>True</td>
<td>150.00</td>
</tr>
<tr>
<td>3337</td>
<td>7/16/2016</td>
<td>7/17/2016</td>
<td>Express Delivery</td>
<td>True</td>
<td>100.00</td>
</tr>
<tr>
<td>3356</td>
<td>8/9/2016</td>
<td>8/10/2016</td>
<td>Parcel Flyers</td>
<td>True</td>
<td>150.00</td>
</tr>
</tbody>
</table>
Lesson 6: Creating a Crosstab Report

A report with quantities of different products that are sold in different regions and their sales totals is needed. You are required to create a crosstab that can clearly represent the necessary information, which allows the sales manager to easily compare the sales of different products in different regions.

Here is the sketch that is given to you:

<table>
<thead>
<tr>
<th>Product Sales Analysis</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category 1</td>
</tr>
<tr>
<td>Country 1</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Country 2</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Country 3</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Country 4</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Total</td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

Follow the tasks below to finish creating the report:

**Task 1: Create the crosstab**

**Task 2: Format the crosstab**

**Task 3: Change the page layout of the report**

**Task 4: Save the report style as a CSS file**

**Task 1: Create the crosstab**

Before taking this task, make sure you have enabled the Insert field name label with field option in the Options dialog as described at the last step of Lesson 3. Otherwise, the name labels will not be inserted together with the fields when you add fields to the crosstab.


2. In the Select Component for Page Report dialog, select Crosstab and click OK.
Be sure that JinfonetGourmetJava.cat is specified as the current catalog because it is the catalog we use in this track. For information about specifying this catalog, see Task 1, Step 2 and 3 of Lesson 1.

3. In the Data screen of the Crosstab Wizard, click <New Query...> in the Queries node of Data Source 1, input ProductSalesAnalysis in the Enter Query Name dialog and click OK.

4. In the Add Tables/Views/Queries dialog, expand the JDBC connection node and then the Tables node, then select the Customers, Orders, Orders Detail and Products tables and click ➡️ to add them to the query. Click OK to close the dialog.

5. In the Query Editor, the tables are joined together automatically based on the auto join criteria. Check all the columns in the Orders Detail table by selecting the * checkbox. For the Customers table, check the following columns: Customer Name, Customers_City, Customers_State, Customers_Country, Customers_Territory and Customers_Region, and for the Products table, the following columns: Products_Product ID, Product Name, Category, Product Type Name and Price.

![Query Editor Screen](image)

You may notice that here we do not check any columns in the Orders table, that is because in this report, columns in this table are not needed but we need this table to create joins between tables in the query.

6. Click OK at the bottom of the Query Editor to create the query.

7. In the Display screen, add the DBField Category to the Columns box by selecting it and clicking ➡️, add Customers_Country to the Rows box by selecting it and clicking ➡️, add the Quantity DBField and Total formula to the Summaries box by selecting them and clicking ➡️ one by one, and then double-click in the Aggregate text box and select Sum from the drop-down list to change the aggregate function of the two summaries.
8. Click **Style** to switch to the screen and select **Simple** from the Style list, then click **Finish** to create the crosstab report.

**Task 2: Format the crosstab**

In this task, we will format the crosstab to make it look more professional.

1. Right-click on the crosstab and select **Position > Absolute**, then drag it to the following position:
By setting the Position property of an object to absolute, the object will be located at the position specified by dragging and dropping or by setting its X and Y coordinate property values.

2. Drag **A** from the Basic group in the Components panel to add three labels in the report, then double-click each label to edit the text respectively to **Product Sales Analysis**, **Units** and **Sales**. Resize and adjust the crosstab and the three labels to place them as follows:

![Crosstab and labels diagram]

Next, we will edit properties of the crosstab report objects in the Report Inspector to improve the appearance of the report.

3. Select the **Units** label and edit its Bold property to **true**, Background property to **Gray** and Foreground property to **White**.
4. Select the Sales label and edit its Bold property to true, Background property to 0x99ccff and Foreground property to White.

5. Select the field on the column header (Category field) and edit its Background property to 0x99ccff and Foreground property to White.

6. Select the two Total cells, the field on the row header (Customers_Country field) and the four ###### cells in the crosstab by holding the Ctrl key on the keyboard, and then specify their Foreground property to Gray.

7. Select the four #,###.00 cells by holding the Ctrl key on the keyboard, change their Foreground property to 0x99ccff, Bold
property to true and Format property to $#,###.00.

8. Select the Product Sales Analysis label, set its Bold property to true, Font Size property to 18, and Foreground property to Red, then resize it to make its text not be truncated.

9. On the report tab bar, right-click the report tab and select Rename to rename it to ProductSales.

10. Click File > Save to save the report as ProductSalesAnalysis.cls.

11. Click the View tab, and the crosstab report appears somewhat like the following one:
Note: If the report does not look correct, you can compare it to the final version of the report provided by JReport. To do so, you will need to save and close this catalog and then open the JinfonetGourmetJava.cat catalog file located at `<install_root>\Demo\Reports\TutorialReports`.

**Task 3: Change the page layout of the report**

When previewing the report, we can see that the crosstab is displayed in two pages. While for a crosstab such a layout is not convenient for users to analyze data, JReport provides the Page Mode feature, using which users can specify how to layout the report pages: in pagination mode or continuous mode. When a report is displayed in continuous mode, the whole report will be laid out in a single page.

1. Click *View > Page Layout*.

2. Click the *View* tab to view the report again. Now, the crosstab is displayed in a single page. We can drag the scroll bar to have a
For a crosstab component, when it is in continuous page mode, we can further set another two properties to determine how many rows and columns we would like to view.

3. Select the crosstab, and set its Items per Row Block and Items per Column Block property values to 3 in the Report Inspector.

4. View the report. Now only three items are displayed in the row and column blocks.

5. Check **Page Layout** on the View menu to switch back to the pagination mode, then the two properties will not take effect.

6. Click **File > Save** to save the report again.

### Task 4: Save the report style as a CSS file

After formatting the report step by step in the Task 2, we can then save the properties into a CSS style file, which can be applied to other crosstab reports directly.

1. Select the crosstab, right-click and select **Save Style** from the shortcut menu.

2. Keep the default settings in the New CSS Style dialog and click **OK**.
3. In the Save CSS As dialog, enter **Crosstab.css** in the File Name field, then click **Save** to save the file to the default directory `<install_root>\style`.

The CSS Style Definition for CrosstabObject dialog appears.

4. Add all the properties of the crosstab from the All Properties box to the Selected Properties box by clicking , then click **Save** to save these properties in the crosstab.css file.

Now, the style of the crosstab report has been saved as a CSS file. Properties in the file can be applied to corresponding components of other reports directly by selecting the CSS file in the `<Import CSS File...>` drop-down list on the toolbar of JReport Designer.
Lesson 7: Creating a Tabular Report

A report about performance of products is needed, in which the product ID is less than or equals to 10. The report includes annual sales of every product in every region, their unit price, the quantities that are sold, and the total of their annual sales of every product. The report should contain a crosstab, which is to represent annual sales of ten products in every region, a chart object, which is to represent quantities and total annual sales of these specified products, and a banded object, which is to represent the unit price and quantities.

Here is a sketch of the report that you can refer to:

In this lesson, we will create a tabular report and insert crosstab object, chart object and banded object respectively into different tabular cells, so that components in the report can be arranged easily with the tabular layout. Meanwhile, all the data resources we need for creating the report have been predefined in the JinfonetGourmetJava.cat catalog file, so in this lesson, we do not need to create them ourselves.

Follow the tasks below to finish creating the report:

Task 1: Create the tabular report
Task 2: Add components to the tabular report

Task 3: Format the report

Task 1: Create the tabular report


2. In the Select Component for Page Report dialog, select Tabular and click OK.

Be sure that JinfonetGourmetJava.cat is specified as the current catalog because it is the catalog we use in this track. For information about specifying this catalog, see Task 1, Step 2 and 3 of Lesson 1.

3. In the Tabular Wizard, keep the default settings and click Finish to create a 2*2 tabular.

4. A message dialog appears prompting you to drag and drop data fields and components to the blank report. Click OK in the
message dialog to close it.

Now a blank report with a 2*2 tabular is generated. In the Report Inspector, they are respectively named TabularCell and TabularCell1 (the two cells in the first row of the tabular); TabularCell2 and TabularCell3 (the two cells in the second row of the tabular). We can then insert different components into the cells, so that they can be easily aligned just by adjusting the tabular cells.

The tabular fills the whole page panel, we can resize it by just dragging its cell borders. In this lesson, in order to make screen captures, we zoom out the tabular first.

**Task 2: Add components to the tabular report**

Before taking this task, make sure you have enabled the Insert field name label with field option in the Options dialog as described at the last step of Lesson 3. Otherwise, the name labels will not be inserted together with the fields when you add fields to the report.

In this task, we will add three components - a crosstab, a chart and a banded object respectively to TabularCell, TabularCell2 and TabularCell3 and make them share the same dataset so as to improve performance.

1. Select the two cells in the first row of the tabular (TabularCell and TabularCell1) by holding the Ctrl key on the keyboard, right-click and then select Merge from the shortcut menu.

2. Select the merged tabular cell and click Insert > Crosstab. The Create Crosstab wizard appears.

3. In the Data screen of the wizard, select the query ProductPerformance from the Queries node of Data Source 1, then click Next.

4. In the Display screen, add the Products_Product ID DBField to the Columns box by selecting it and clicking , add the Region_AbbreviationName formula to the Rows box by selecting it and clicking , add the Total formula to the Summaries box by selecting it and clicking , and then double-click in the Aggregate text box and select Sum from the drop-down list as the aggregate function of the summary.
5. Click **Style** to switch to the screen and apply the **Classic** style to the crosstab, then click **Finish** to close the Create Crosstab wizard and place the crosstab in the first tabular cell row.

Next, we will insert the chart object to TabularCell2:

6. Select the left cell in the second row of the tabular (TabularCell2) and click **Insert > Chart**. The Create Chart wizard appears.

7. In the Data screen of the wizard, click the **More Options** button, then check the **Existing Dataset** radio button and select the dataset **ProductPerformance**. Click **Next**.
8. In the Type screen, select the **Bubble** in the Chart Type box and click **Next**.

9. In the Display screen, select the **Y Axis** node in the Show Values box, drag and drop the summary **Count_QuantitybyProductID** under it, then select the **Radius** node and add **Sum_ProductSalesbyProductID** under it. The summaries are grouped by the **DBField ProductID_FK1** so the field is added to the Category box automatically. Leave the Series box empty.
10. Click **Layout** to switch to the screen, select **Title** in the Options box, then specify Category (X) Axis Title as **Product ID**, and Value (Y) Axis Title as **Quantity**. Click **Next**.

11. In the **Style** screen, select **Classic** from the Style list. Click **Finish** to close the Create Chart wizard and drop the chart in TabularCell2.

Next, we will insert the banded object to TabularCell3:

12. Select TabularCell3 (the right cell in the second row of the tabular), and then click **Insert > Banded Object**. The Create Banded Object wizard appears.

13. In the Data screen of the wizard, click the **More Options** button, then check the **Existing Dataset** radio button and select the dataset **ProductPerformance**.

14. Click **Group** to switch to the screen, select the DBField **ProductID_FK1** and click \(\rightarrow\) to add it as the group by field.

15. Go to the **Style** screen and select the **Classic** style for the banded object. Click **Finish** to close the Create Banded Object wizard.
and then click in TabularCell3 to place the banded object in it. The panels in the banded object are identified on the left side by their abbreviations: a banded header panel (BH), a banded page header panel (BPH), a group header panel (GH), a detail panel (DT), a group footer panel (GF), a banded page footer panel (BPF) and a banded footer panel (BF).

Now, the three objects look as follows in the tabular:

16. From the Toolbar panel, drag a label to the BPH panel in the banded object, above the group by field in the GH panel to label the field, then edit the label text to Product ID.

17. Drag the DBFields Unit Price and the summary Count_QuantitybyProduct ID from the Data panel and drop them in the GH panel.

18. Adjust the added field and summary, move their name labels to the BPH panel, and edit the name label Count_QuantitybyProduct ID to Quantity.

19. Right-click in the BH panel and select Hide from the shortcut menu to hide it from view. Repeat this to hide all panels that do not hold data.

Now the report shows as follows:
Next, we need a report title for the tabular report to make the report look professional.

20. Right-click the tabular cell that holds the crosstab, and select **Insert Row Above** from the shortcut menu, then resize the row to a suitable height.

21. Double-click the newly-created tabular row, and enter the text **Product Performance by Product ID** as the report title.

As required, the report only needs to show the products performance from the Product ID 1 to 10, so next we will use the Dataset Filter feature to limit data selected from the dataset. Since all the components in the report share the same dataset, the filter will be applied to all of them.

22. Click the **Dataset Filter** button on the toolbar of the Data panel.

23. In the Dataset Filter dialog, click the **Add Condition** button to add a filter line, select **PRODUCTID_FK1** from the field drop-down list, **<=** from the operator drop-down list, and enter **10** in the value text field to specify the filter condition as **PRODUCTID_FK1 <= 10**, then click **OK**.
Task 3: Format the report

To improve the report appearance, we need to do some adjustments to the report, as well as the components in it:

1. Resize the tabular cells according to the components’ sizes in every cell, so that they will not be truncated by the tabular and can display well.

Next, we will further format to improve the appearances of the components. First, we will format the report title and the crosstab.

2. Select the text **Product Performance by Product ID**, right-click on it and select **Font** from the shortcut menu.

3. In the Font tab of the Format Text dialog, set Font to **Arial**, Font Size to **18**, Font Color to **Red** and Bold to **true**, then click **OK**.

   The title appears as follows:

   ![Product Performance by Product ID](image)

4. Select the four DBFields in the summary area of the crosstab, then in the Report Inspector, specify the Height property to **0.25**, Width to **0.59**, and Format to **#,###.##**.
Next, let's format the chart.

5. Double-click the label *Quantity* in the chart, then in Format Label dialog, switch to the *Font* tab, set Font Size to *10pt* and Font Color to *808080*. Click OK to accept the settings.

![Format Label dialog](image)

6. Use the same way to format the label *Product ID* in the chart.

7. Right-click the chart and then click *Hide Legend* on the shortcut menu to hide the legend.

Then, we will format the banded object.

8. Select the *Product ID* name label in the BPH panel and its corresponding field in the GH panel by holding the Ctrl key on the keyboard, then click the Right button on the toolbar to make them aligned the same as other labels and fields in the banded object.

9. Select the three DBFields in the GH panel by holding the Ctrl key on the keyboard, then in the Report Inspector set their Foreground property to *Black* and Bold to *false*.

10. Select the *Unit Price* DBField and then specify its Format property to *$#,##0.00* in the Report Inspector.
After doing the adjustments, the report appears somewhat like follows in design view:

![Image of report design view]

According to the sketch, a line needs to be added below the report title. We can do this just by setting tabular cell properties.

11. Select the tabular cell holding the report title, then in the Report Inspector, specify its Top Line, Left Line and Right Line properties to none, Border Color to Gray and Border Thickness to 0.01.

When viewing the report, the crosstab object displays much closer to the line we just customized and the other two components look too clumsy. We need to do some adjustments, which can be done easily by using the function of a tabular.

12. Right-click the tabular cell holding the crosstab, and then select Insert Row Above from the shortcut menu. Right-click the cell again and select Insert Row Below.

Two rows are now added above and below the crosstab.
13. Resize the tabular rows to adjust the distances between the crosstab and the other components.

14. On the report tab bar, right-click the report tab and select Rename to rename it to ProductPerformance.

15. Click File > Save to save the report as ProductPerformancebyProductID.cls.

16. Click the View tab, and the report appears as follows, depending on what formatting you have done to the components.
Note: If the report does not look correct, you can compare it to the final version of the report provided by JReport. To do so, you will need to save and close this catalog and then open the JinfonetGourmetJava.cat catalog file located at <install_root>\Demo\Reports\TutorialReports.
Lesson 8: Creating a Report That Contains a Subreport

Here we need to create a report that contains a subreport to show the order detail information, the related customers and employees information.

This lesson shows a report combined with another report. When adding report A into report B, the report A is referred to as a subreport, while report B is considered as a primary report. We will first create a page report that contains two report tabs - one is about orders detail information, and the other is about a tabular report with two charts of different types.

In this lesson, we take the first report tab in the page report as the primary report, and the second one as the subreport. So that we can insert the second report tab to the first one to show the sales total by orders in different order ID groups.

Follow the tasks below to finish creating the report:

Task 1: Create a page report that contains two report tabs

Task 2: Insert a subreport to the report

Task 1: Create a page report that contains two report tabs

Before taking this task, make sure you have enabled the Insert field name label with field option in the Options dialog as described at the last step of Lesson 3. Otherwise, the name labels will not be inserted together with the fields when you add fields to the report.


2. In the Select Component for Page Report dialog, select Banded and click OK.

3. Be sure that JinfonetGourmetJava.cat is specified as the current catalog because this is the catalog we use in this track. For information about specifying this catalog, see Task 1, Step 2 and 3 of Lesson 1.

4. In the Data screen of the Banded Wizard, expand the Imported SQLs node in Data Source 1 and select OrdersReport.
5. Click **Style** to switch to the screen and select the **Simple** style for the report, then click **Finish**.

A report with a blank standard banded object is created as follows. The panels in the banded object are identified on the left by their abbreviations: a banded header panel (BH), a banded page header panel (BPH), a detail panel (DT), a banded page footer panel (BPF) and a banded footer panel (BF).
For users who wish to write their own SQL statement, JReport enables them to put the SQL statement into a file and then load them from this file. SQL files can work like queries in JReport.

In this lesson, we need to group data by Order IDs, so we will add a group to the banded object.

5. Right-click the banded object and then select Banded Wizard from the shortcut menu.

6. In the Group screen of the Banded Wizard, add the DBField Orders_OrderID as the group by field by selecting it and clicking \( \rightarrow \), then click Finish.
7. Resize the GH panel of the banded object, drag the fields Customer_Name, Orders_OrderDate, Contact_LastName and Orders_PaymentReceived from the Data panel and drop them into it.

8. Double-click and edit the Customer_Name, Orders_OrderDate, Contact_LastName and Orders_PaymentReceived name labels to Customer Name, Order Date, Employee Last Name and Payment Received one by one.

9. Align the newly-added objects and resize them in the GH panel as follows:

10. Resize the group by field in the GH panel, click Insert > Label to add a label ahead of it and edit its text to "Order ID:"

11. Select the Order Date DBField and set its Format property to M/d/yyyy in the Report Inspector.

12. Select the BPH panel, click Insert > Label to add a label in it and edit its text to Order Details. The label will then be shown in every page as the report title.

13. Hide the BH, DT, GF, BPF and BF panels one by one by right-clicking the panel and selecting Hide from the shortcut menu.

14. Format labels and DBFields in the report to improve their appearance. Here, we will not describe the formatting process in detail, you can refer to Task 3 of Lesson 1 for assistance.

Then the first report tab in the report is created to show the order detail information as follows in design mode:
15. On the report tab bar, right-click the report tab and select **Rename** to rename it to **OrderDetailInformation**.
Next, we will create the second report tab in the report.


17. In the Select Component for Page Report Tab dialog, select Tabular from the layout box, then click OK.

18. In the Tabular Wizard, keep the default settings and click Finish. A report tab with a blank 2*2 tabular is created.

19. Merge the tabular cells into two rows by selecting two cells in a row while holding the Ctrl key on the keyboard, right-clicking on them and selecting Merge from the shortcut menu, then adjust them in order to place the bar chart and pie chart vertically in the report tab.

Next, we will insert the two charts into the tabular cells and have them share the same dataset as the OrdersDetailInformation report tab.

20. Select the first tabular cell and click Insert > Chart on the menu bar.

21. In the Data screen of the Create Chart wizard, click the More Options button, check the Existing Dataset radio button, then select the dataset OrdersReport. Click Next.

22. In the Type screen, keep the default chart type Clustered Bar 2-D and click Next.

23. In the Display screen, select the summary Sum_SQLProductSalesbyOrderID and click beside the Show Values box, Orders_OrderID is then added automatically to the Category box.

24. Click Style the switch to the screen and select Basic from the Style list. Click Finish to create the chart.

25. When a box attached to your mouse pointer, click the tabular cell to place the chart there.
26. Select the second tabular cell and insert a pie chart in it which uses the same dataset and displays the same data in the same style with the bar chart.

27. Right-click the bar chart and select Add Label from the shortcut menu. A label is then added to the chart.

28. Move the label to the top of the chart, then double-click it to display the Format Label dialog.

29. In the General tab, change the label text to Current Orders for This Customer.

30. Switch to the Font tab, change Font Size to 12pt, Font Color to 808080 and click OK.
31. Resize the label to make sure the text is displayed completely.

32. Add a label to the pie chart and format it using the same way and edit its text to **Current Orders for This Employee**.

33. In the Report Inspector, select the **Chart Object** and **Chart Object 1** nodes from the report structure tree by holding the Ctrl key on the keyboard, then change the Border Type properties to **none**.
34. Select the **Chart Legend Object** and **Chart Legend Object 1** nodes and change the Border Type property to **None** as well.

35. Further format the two charts to improve their appearance if desired. For details about formatting chart, you can refer to Task 2 of Lesson 4.

Now the second report tab in the report is created to show the sales total by orders.

36. On the report tab bar, right-click the report tab containing the charts to rename it to **Sub_OrderDetails**.

37. Click **File > Save** to save the report as **OrdersReport.cls**.
Task 2: Insert a subreport to the report

After creating the report, we can insert the subreport to the primary report by specifying relationships between them. In this lesson, we can specify different relationships between the primary report (the first one) and the two chart components in the second report tab by setting up different links between them. Then JReport will build a subreport for every order with the conditions, so that it is convenient to see the corresponding customer and employee information of every order.

We want this subreport to be at the end of the existing reports, thus we need to add a second group header and add the subreport to the new header.

1. Click OrderDetailInformation on the report tab bar to switch to the report tab.

2. Right-click in the GH panel of the banded object and choose Insert Panel After from the shortcut menu.

3. Select the newly-added panel and click Insert > Subreport.

4. When a box attached to the mouse pointer, click the newly-added panel to place the subreport into it, and the Subreport dialog appears.

5. Click the Browse button, select OrdersReport.cls and then click Open.

6. Select Sub_OrderDetails from the Report Tab drop-down list.

7. Click the Add button beside the Component in Report Tab box in the Field tab, choose ChartObject in the Choose Component dialog, then click OK.
8. Build the relationship between the primary report and the selected chart object on the Orders_CustomerID field by selecting the field and clicking right arrow.
9. Click the **Add** button again, this time choose **ChartObject1** in the Choose Component dialog, then click **OK**.

10. Build the relationship between the primary report and the second chart object on the **Orders_EmployeeID** field.

11. Click **OK** in the Subreport dialog and the report tab will be inserted in the **OrderDetails** report tab as follows:
Next, we will filter the dataset used by report tabs in the report so as to enhance the performance when running the report.

12. Click **Report > Manage Datasets** to display the Manage Datasets dialog.

   The Manage Datasets dialog lists all the dataset used in the current report. In our report, all the components share the same dataset, so here only one dataset is shown.

13. Click the **Filter** tab, click the **Add Condition** button to add a filter line, select **ORDERS_ORDERID** from the field drop-down list, <= from the operator drop-down list, and enter **3050** in the value text field to specify the filter condition as **ORDERS_ORDERID <= 3050**, then click **OK**.

![Manage Datasets dialog](image)

14. Click **File > Save** to save the report.

15. Click the **View** tab, the report tab that contains a subreport is displayed as follows: the primary report shows the orders detail information grouped by order ID, and the subreport shows the orders information by different customers and different employees respectively in the two charts.
As you learned in this lesson, it is very convenient to build up a library of reports that act as components that you can add to various primary reports. Properly designed and used, subreports save a lot of time and effort in rapidly adapting your applications to changing user requirements and needs.

Note: If the report does not look correct, you can compare it to the final version of the report provided by JReport. To do so, you will need to save and close this catalog and then open the JinfonetGourmetJava.cat catalog file located at \install_root\\Demo\Reports\TutorialReports.

Order Details

Order ID: 3063

Customer Name: Guatemala Coffee Hut
Order Date: 1/4/2015
Employee Last Name: Sheffield
Payment Received: False

Current Orders for This Customer

Current Orders for This Employee

33,166.8
Lesson 9: Creating a Parameter-based Report

In Lesson 1 of this track we created a page report that contains an order list report tab to show order lists of every month from 2015 to 2016. Now, the sales manager is asking for this same report but with different orders during a specified time. Instead of building a new report about orders in each order date, we will save the page report as a new one and then modify the dataset used by its report to meet the requirements.

Follow the tasks below to finish creating the report:

Task 1: Create the parameters

Task 2: Modify the dataset of the report to use the parameters

Task 3: Preview and test the report

Task 1: Create the parameters

1. In JReport Designer menu click File > Open to open the report OrderListbyDate.cls created in Lesson 1 in the JinfonetGourmetJava.cat catalog file.

2. Click File > Save As to save the report as OrderListbyDate_Parameter.cls. Then we begin to modify this report instead of the former one.

3. In the Data panel, click the <New Parameter...> item in the Parameters node.
4. In the New Parameter dialog, enter **pStartDate** in the Name field, keep the default Value Setting, select **DateTime** from the Value Type drop-down list, click + to add a value row in the Value List box and enter "May 1, 2016 8:00:00 AM" as the prompting value, and then input "Please input start date:" as the prompting text. Click OK to create the parameter.
5. Repeat steps 3 to 4 to create another parameter with the following values:

- **Parameter Name**: pEndDate
- **Value Setting**: Type-in Parameter
- **Value Type**: DateTime
- **Prompting Values**: June 1, 2016 8:00:00 AM
- **Prompting Text**: Please input end date:

**Task 2: Modify the dataset of the report to use the parameters**

In this task, we will apply the parameters created above to filter the dataset which is used by the report. Then when we view the report, we can specify different parameter values to dynamically filter the report to get data in the desired time period.

1. On the Data panel toolbar, click the **Dataset Filter** button.

2. In the Dataset Filter dialog, click the **Add Condition** button to add a filter line, select **ORDER DATE** from the field drop-down list, set >= as the operator, then click  

3. In the Expressions dialog, double-click the **pStartDate** parameter to use it as value of the filter condition. Then close the Expressions dialog.
4. Click **Add Condition** button to add another filter line. The relationship between the two filters will be And.

5. Specify condition of the newly added filter as follows:
6. Click OK in the dialog to apply the settings.

Parameters can also be used to filter queries to limit their data. However, in this task, we cannot set the filter on the report’s query. If we do that, all datasets based on the query will be affected, that is to say, the filter will also be applied to the report created in Lesson 1.

**Task 3: Preview and test the report**

After the steps above, readers of this report can input any date to get orders with the time they need by specifying the parameter values dynamically.

1. Click the View tab to preview the report.

   JReport recognizes that the query is based on the value of two parameters, and therefore prompts for them as follows:
2. Specify the start date and end date as required in the combo boxes or click the calendar icon to select the date.

3. Click the **Default** button to generate the report output based on the default values for the parameters. The report is displayed as follows, showing information for orders from May 1, 2016 8:00:00 AM to June 1, 2016 8:00:00 AM only:
Order List by Date

<table>
<thead>
<tr>
<th>Order Date</th>
<th>Date</th>
<th>Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>5/2016</td>
<td>10/19/2017</td>
<td>6:32:56 PM</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Order ID</th>
<th>3295</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Product Type Name</th>
<th>Product ID</th>
<th>Product Name</th>
<th>Category</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decaf</td>
<td>12</td>
<td>House Blend</td>
<td>Bold</td>
<td>4,210.84</td>
</tr>
<tr>
<td>Decaf</td>
<td>17</td>
<td>Java Dragon Blend</td>
<td>Mild</td>
<td>7,585.80</td>
</tr>
<tr>
<td>Regular</td>
<td>21</td>
<td>Kenya Peabody</td>
<td>Exotic</td>
<td>2,760.48</td>
</tr>
<tr>
<td>Decaf</td>
<td>27</td>
<td>Kona Mountain</td>
<td>Blends</td>
<td>11,045.65</td>
</tr>
</tbody>
</table>

Total by Order: 25,602.77

<table>
<thead>
<tr>
<th>Order ID</th>
<th>3296</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Product Type Name</th>
<th>Product ID</th>
<th>Product Name</th>
<th>Category</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decaf</td>
<td>4</td>
<td>Organic Espresso Decaf</td>
<td>Espresso</td>
<td>3,402.52</td>
</tr>
<tr>
<td>Regular</td>
<td>29</td>
<td>Colombia El Tambo</td>
<td>Blends</td>
<td>5,844.00</td>
</tr>
<tr>
<td>Decaf</td>
<td>31</td>
<td>Gold Coast Blend</td>
<td>Blends</td>
<td>8,072.25</td>
</tr>
</tbody>
</table>

Total by Order: 17,318.77

<table>
<thead>
<tr>
<th>Order ID</th>
<th>3297</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Product Type Name</th>
<th>Product ID</th>
<th>Product Name</th>
<th>Category</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decaf</td>
<td>2</td>
<td>Espresso Roast Decaf</td>
<td>Espresso</td>
<td>1,595.57</td>
</tr>
<tr>
<td>Regular</td>
<td>7</td>
<td>Rift Valley Blend</td>
<td>Exotic</td>
<td>3,325.59</td>
</tr>
<tr>
<td>Decaf</td>
<td>14</td>
<td>Sumatra-Decaf</td>
<td>Mild</td>
<td>1,048.10</td>
</tr>
</tbody>
</table>

Note: If the report does not look correct, you can compare it to the final version of the report provided by JReport. To do so, you will need to save and close this catalog and then open the JinfonetGourmetJava.cat catalog file located at `<install_root>\Demo\Reports\TutorialReports`. 
Track 2: Creating Business Views

Business views are the data sources used for creating web reports and library components in JReport Designer, as well as creating ad hoc reports and performing visual analysis in JReport Server. They enable report developers and end users to build reports and analyze data based on a set of view elements that they can easily understand. For example, they do not need to worry about where the data source is from (SQL, stored procedure, view, etc.), or what the data source is (Oracle, Sybase, XML, etc.). Business views also enable IT professionals to maintain control of business data and to ensure its integrity, while presenting end users with an intuitive view of the underlying data.

Business views are created and managed in JReport Designer. A business view is built from four kinds of elements:

- **Group objects** are typically DBFields and formulas by which you want to group data. They present the availability and key performance of data, and characteristically return text data or dates, and answer the following question: who, when, what, where and which.

- **Aggregation objects** are typically numeric DBFields and formulas to which an aggregate function, such as Sum, is applied or they can be an existing aggregation from the catalog.

- **Detail objects** can be any DBField or formula, typically they are values that you would want to display in the Detail section of a table. They can not be used in charts and crosstabs.

- **Categories** are simply folders for organizing the other three elements.
A business view can also contain hierarchies. A hierarchy is defined as a hierarchy category holding one group of group objects sharing a hierarchical relationship, following the order from the highest level to the lowest. Hierarchies allow end users to drill report data up and down to particular groups at runtime.

In this track, we will create a business view based on data in Data Source 1 of the JinfonetGourmetJava catalog, which provides data information about customers, orders, orders detail and products.

This track contains the following tasks:

Task 1: Create the business view

Task 2: Add elements to the business view

Task 3: Define hierarchies in the business view

Note: A JReport Live license for JReport Designer is required in order to perform this track. If you do not have the license, please contact your Jinfonet Software account manager to obtain it first.

**Task 1: Create the business view**

In this task we will create the business view to include the needed tables.

1. Click **Start > JReport 15 > Report Designer** to start JReport Designer. The JReport Designer window with the Start Page appears.

Close the Start Page.
2. Click File > Open Catalog to bring out the Open Catalog File dialog.

3. Browse to select the JinfonetGourmetJava.cat catalog file in <install_root>\Demo\Reports\JinfonetGourmetJava, then click the Open button. The Catalog Manager is displayed.

4. Expand the Data Source 1 node, then right-click the Business View node and click New Business View on the shortcut menu.

5. Type in WorldWideSalesBV in the Enter Business View Name dialog and click OK.

6. In the Add Tables/Views/Queries dialog, expand the JDBC connection node and then the Tables node, then select these tables:
Customers, Orders, Orders Detail and Products, click ▶️ to add them to the right box, then click OK.

7. The four added tables are displayed with their columns and automatically joined based on the auto join criteria in the Query Editor.
8. In the Customers table, check the * checkbox to select all columns in the table, then uncheck these columns: Address2, Customers_Fax, and Annual Sales. In the Orders table, select Orders_Order ID, Order Date, and Payment Received. In the Orders Detail table, select Unit Price, Quantity, and Discount. In the Products table, select all its columns first by checking *, then unselect Inventory and Reorder Level.

9. Click OK at the bottom of the Query Editor.

The Business View Editor is then displayed. The tables and table columns selected in steps 6 and 8 are displayed in the Resource Objects panel in the editor, and the formulas and summaries that are valid to them are also available in the panel. We can then create view elements based on these resources.
Task 2: Add elements to the business view

We will create three categories in the business view to hold customer, order and product information respectively.

1. In the Business View panel of the Business View Editor, select WorldWideSalesBV and right-click, then select Add Category from the shortcut menu.
2. In the Category Property dialog, input **Customers** as the Display Name, then click **OK**.

3. Expand the **WorldWideSalesBV** node in the Business View panel to display the newly added category.
4. Expand the **Customers** table in the Resource Objects panel, select the fields **Customer Name**, **Customers_City**, **Customers_Country**, **Customers.Region**, **Customers_State**, and **Customers_Territory** in the table, then drag them into the Customers category in the Business View panel.
5. Change their display names using the shortcut menu option Rename to **City**, **Country**, **Region**, **State**, and **Territory**, by removing "Customers_". Then select **Customer Name** and click twice to move it below **Country** to make the objects displayed in alphabetical order.

6. Select the **Customers** category and click **New Category** on the toolbar to create a sub category **Address** in it, which will used to hold address information. Move the **Address** category above the **City** group object by using the button .
7. From the Customers table in the Resource Objects panel, select **Address1, Customers.Country, Customer Name,** and **Customers.Phone** and drag them into the Address category.

When adding elements to a business view by dragging DBFields from the Resource Objects panel, the elements will be used as Group object by default. So next we will manually edit the type of the elements in the Address category to Detail so that they can be used to show detail information in reports.

8. Select **Customers.Country**, right-click it and select **Edit** on the shortcut menu. In the Edit View Element dialog, edit its display name to **Country** and type to **Detail**, then click **OK**. Edit the display name of **Customers.Phone** to **Phone** and type to **Detail** using the same
way. Then select Address1 and Customer Name, right-click and select Edit to edit their type to Detail at the same time in the Edit View Element dialog.

By now the Customers category is finished. Next, we are going to create the Orders Detail category.

9. Select WorldWideSalesBV in the Business View panel, then click New Category on the toolbar to create a category Orders Detail. Add these fields from the Resource Objects panel into the category: all the fields from the Orders and Orders Detail tables, and Cost from the Products table. Use the shortcut menu option Rename to edit the display name of Orders_Order ID to Order ID. Arrange the order of the added fields to make them sorted in alphabetical order. Edit the type of Cost, Discount, Order Date, Quantity and Unit Price to
Detail using the Edit View Element dialog. See the result:

View elements can also be added into a business view by using a dialog instead of dragging and dropping. Next, we are going to add more objects to the Order Detail category using a dialog.

10. Select the Orders Detail category, right-click it and select Add View Element from the shortcut menu.

11. In the Add View Element dialog, click ..., next to the Mapping Name text field, in the View Element Resources dialog expand the Formulas node and double-click Total to add it as the mapping field, then set Type to Detail and click OK to create the detail object.
12. Select the **Orders Detail** category again and click **New Aggregation** on the toolbar.

13. In the Add View Element dialog, type **Total Cost** in the Display Name text field, click the ellipsis next to the Mapping Name text field to
double-click **Cost** in the Products table, select **Sum** from the Aggregate Function drop-down list. Click **OK** to create the aggregation.

14. Create another two aggregations **Total Quantity** which sums on Quantity and **Total Sales** which sums on the formula **Total** using the same way.

15. Arrange the objects in the Orders Detail category in alphabetical order:
Next, we will create the Products category to hold product related information.

16. Create a category **Products** in WorldWideSalesBV, add **Category**, **Product Name**, **Product Type Name**, and **Products_Product ID** from the Products table in the Resource Objects panel to it, modify the display names of **Product Type Name** to **Product Type** and **Products_Product ID** to **Product ID**, then arrange the objects in alphabetical order.
17. Click **Save** on the Business View Editor toolbar to save the business view.

**Task 3: Define hierarchies in the business view**

In this task, we will define two hierarchies in the business view: one containing customer’s geographic information, from region down to city, and the other product's hierarchical groups.

1. In the Business View Editor, select **WorldWideSalesBV** in the Business View panel, then click **New Hierarchy** on the toolbar.

2. In the New Hierarchy dialog, input **Geography** and click **OK**. The Geography hierarchy node is then added at the bottom under the
3. In the Business View panel, drag these objects **Region**, **Territory**, **Country**, **State** and **City** from the Customers category one by one following this order to the Geography hierarchy node. Region will be the highest level and City the lowest.

4. Follow steps 1 to 3 to create another hierarchy named **Product**, then add **Product Type**, **Category** and **Product Name** to the hierarchy.

Now, two hierarchies have been defined in the business view.
5. Save the business view to save the hierarchies, then close the Business View Editor.

6. Click **Save Catalog** on the Catalog Manager toolbar to save the business view into the catalog.
Track 3: Creating Web Reports

JReport provides the web reporting solution that is aimed at easier and faster report creation and design, faster report execution, easier customization, and better presentation style using the newest Web technology. Web reports are viewed using a new interactive viewer called Web Report Studio, which provides a much nicer end user experience with many powerful features for interfacing with a report such as changing parameters without re-running the report.

In JReport Designer, report developers can create, open and edit web reports. Web reports created on JReport Server can also be downloaded to JReport Designer for further editing.

In this track we will create a web report as the role of a report developer, based on the business view WorldWideSalesBV created in the previous track. The report will show each product's sales information, including order ID, order date, quantity, unit price, discount, and the total sales for each order. We will use a table to display the information, plus a chart to demonstrate the total sales of each product. In order for end users to see sales information within a specific range, such as country or product name, we will add filter controls for dynamically filtering the data according to their requirements.

This track contains the following tasks:

Task 1: Create the initial report

Task 2: Improve the report layout

Task 3: Format the report components

Task 4: Preview the report in Web Report Studio

Note: A JReport Live license for JReport Designer is required in order to perform this track. If you do not have the license, please contact your Jinfonet Software account manager to obtain it first.

Task 1: Create the initial report


   Close the Start Page.

2. Click File > Open Catalog.
3. In the Open Catalog File dialog, browse to select the JinfonetGourmetJava.cat catalog file in `<install_root>\Demo\Reports\JinfonetGourmetJava`, then click the Open button.

The Catalog Manager is displayed. Close it since we will not use it in the lesson.

4. Click File > New > Web Report. A blank report with a one-cell tabular is created.

5. Right-click the report body, select Split from the shortcut menu.

6. In the Split Cell dialog, set both numbers to 2, then click OK.

The report body is now hosted by four tabular cells. We will put the filter controls in the left cells, a chart and a table in the right cells.

First we create a chart to demonstrate the total sales of each product.

7. Select the right cell in the first tabular row, then click Insert > Chart. The Create Chart wizard appears.

8. In the Data screen, select WorldWideSalesBV. Click Next.

9. In the Type screen, keep the default chart type Clustered Bar 2-D and click Next.

10. In the Display Screen, add Product Name in the Products category to the X-Axis box and Total Sales in the Orders Detail category to the Bar Length box.
11. Click Style to switch to the screen, select ClassicBlue as the chart style, then click Finish to create the chart.

Next, we will create a table to display the sales information just below the chart.

12. Select the right cell in the second tabular row, then click Insert > Table. In the Table Type dialog, keep the default selection and click OK. The Create Table wizard is displayed.

13. In the Data screen of the wizard, select WorldWideSalesBV and click Next.

14. In the Display Screen, drag the following elements in the Orders Detail category to be displayed in the table one by one: Order ID, Order Date, Quantity, Unit Price, Discount, and Total. Click Next.
15. In the Group screen, add Country and Product Name as the group by fields (Country is the higher group level).

16. Click Style to switch to the screen, then select Neutral as the table style.

17. Click Finish to create the table.

We will add two filter controls to the report, so that at runtime end users can select one or more values in the filter controls to dynamically filter the chart and table.

18. Select the first tabular cell, click Insert > Web Control > Filter Control.

19. In the Insert Filter Control dialog, select Country from the Select Fields drop-down list, click outside of the field drop-down list in the dialog to finish selecting field, then click OK to insert the filter control.
20. Select the left cell in the second tabular cell row to Insert another filter control in the cell, based on the field Product Name using the same way.

Next we will add a navigation control which helps end users deal with the filter applying status in both filter controls in the report: go back to the previous filter applying status, go forward to the next, or clear all the filter applying histories. We will create the navigation control above the chart in the report.

21. Right-click the blank area in the cell the chart is in and select Insert Row Above from the shortcut menu.

22. Select the right cell in the newly added tabular row, click Insert > Web Control > Navigation Control.

Lastly, we will insert an image to show the title of the report in the report page header panel.

23. Select the blank cell above the navigation control, click Insert > Image.

24. In the Select an Image dialog, double-click ProductSalesHeader.gif to insert the image.

Now all the components needed in the report have been inserted in separate tabular cells.

**Task 2: Improve the report layout**

In this task we will make some changes to the position and size of the components to improve the report layout.
1. Drag and drop the components in the tabular cells to make them top-left aligned in each cell, as shown below:

2. Change the height of the tabular cell that holds the navigation control to make it fit the height of the navigation control.

3. Change the width of the tabular cell that holds the table to make sure all columns in the table can be shown.

4. Resize the chart to make it fully occupy the cell it is in.

The cell above the Country filter control is empty, so next we will make the cell merged with the cell that holds the Country filter control.

5. Select the empty cell and the cell the Country filter control is in by pressing the Ctrl key, right-click and select Merge from the
shortcut menu.

6. Resize the two filter controls to make them fully occupy the cells they are in.

The report appears as follows in design view now:

![Product Sales Report](image)

**Task 3: Format the report components**

To improve the report appearance, we need to further format the components in the report. First, we will format the chart.
1. Right-click on the chart and select **Hide Legend** from the shortcut menu.

2. Right-click on any bar, select **Format Axes > Format Value (Y) Axis** on the shortcut menu.

3. In the Format Value (Y) Axis dialog, go to the **Format** tab, select **Number** from the Category box, select **$#,##0** from the Format box, then click **Add** to add the format in the Stack box. Click **OK** to exit the dialog.

Next, we will format the table by editing its object properties in the Report Inspector:

4. In the report structure tree, select the **Table Header** node and set its Background property to **0x7da1d1**.
5. Select the Table Group Header node and set its Background property to 0xd9d9d9, then select Table Group Header 1 and set its Background property to 0xeeeeee.

6. In the table select the two group by fields in the group headers (GH) by holding the Ctrl key, resize them horizontally to make sure the country and product names won't get truncated, then in the Report Inspector, set the Foreground property to 0x7da1d1.

7. Select the Order Date DBField in the detail row (DT), edit its Format property to MM/dd/yyyy.

8. Press the Ctrl key and select the Unit Price and Total DBFields in the detail row, then edit the Format property to $#,###.00.

9. Select the Discount DBField in the detail row and modify its Format property to #,##0.00.

The chart and table now look as follows:
Next, we will format the two filter controls and the navigation control:

10. Select the two filter controls in the report, then in the Report Inspector, set the Border Color property in the Border category to 0x7ca2cf, and Background property in the Title category to 0x7ca2cf.

11. Select the three buttons in the navigation control, then in the Report Inspector modify the Bold property to true, Background to 0x7ca2cf, and Foreground to White.

After doing the formatting, the report appears somewhat like below:
12. Click File > Save to save the report as Products.wls.

**Task 4: Preview the report in Web Report Studio**

In this task we will use the Preview as Web Report Result command of JReport Designer to preview the report and test the filter controls in the report, however this command is enabled only if the option Server for Previewing Reports was specified when installing JReport Designer.

1. Click **View > Preview As > Web Report Result** on the menu bar. The report is opened in Web Report Studio in the default web browser.

You will find that the report layout is not so perfect as Web Report Studio adopts responsive view by default to suit different
mobile devices. To close responsive view, click the Customize Buttons button on the toolbar and select Close Responsive Mode from the menu list. The Close Responsive Mode button is then displayed on the toolbar. Click the button to close responsive view.

We can use the filter controls to dynamically change data displayed in the report. Since the chart and table are based on the same business view and the filter controls use fields from this business view, the filters created via the filter controls will be applied to them both at the same time. First, we want to view the sales in Canada.

2. Click Canada in the Country filter control, then the chart and table is refreshed to display the data for Canada only.
3. To further view the product Kona Mountain's sales in Canada, select Kona Mountain in the Product Name filter control. The report is refreshed to show the corresponding data:
4. Now we would like to see the sales of Blue Mountain, Breakfast Blend and French Roast in all countries. Since the current report data is for Kona Mountain's sales in Canada, we need to remove the filters first. Click on the title bar of each filter control to clear the value selection in them. We can also make use of the navigation control in the report to achieve the same goal: in the navigation control above the chart, click Back twice to undo what we have just done in the above two steps, or click Clear to simply clear the filter conditions in all filter controls.

5. Press the Ctrl key on the keyboard, click Blue Mountain, Breakfast Blend and French Roast in the Product Name filter control, then release the Ctrl key. The report now shows as follows:

You can go to Creating a Web Report the Quick Start Way and Creating a Web Report Using Wizard in the Quick Start part to get more details about working with Web Report Studio.
Track 4: Creating Library Components

Library components are used by end users to build dashboards using JDashboard which is a separately licensed product in JReport Server. Library components are created and edited in JReport Designer, and then published along with their catalog to the component library in JReport Server for use in dashboards.

In this track, we will create two library components in JReport Designer as the role of a report developer, based on the business view WorldWideSalesBV created in the previous track. One library component contains a table that shows each product's order details, including order ID, quantity, unit price, and the total sales for each order. Another library component contains a chart that demonstrates the total sales of each product. We will apply some features that are specific to library components only, such as Message, Slider and Configuration Panel.

Note: A JDashboard license for JReport Designer is required in order to perform this track. If you do not have the license, please contact your Jinfonet Software account manager to obtain it first.

This track contains the following tasks:

Task 1: Create two library components

Task 2: Deliver a message between the library components

Task 3: Insert a slider to filter data

Task 4: Use text field in the configuration panel to change property value

Task 1: Create two library components

Firstly we will create two library components, including a table and a chart.


2. Click File > Open Catalog.
3. In the Open Catalog File dialog, browse to select the JinfonetGourmetJava.cat catalog file in <install_root>\Demo\Reports\JinfonetGourmetJava, then click the Open button.

The Catalog Manager is displayed. Close it since we will not use it in the lesson.


5. Input Product Order Details in the Library Component Title text field, select the Table (Group Above) component type, then click OK.

The Table Wizard is then displayed.

6. In the Data screen of the wizard, select WorldWideSalesBV and click Next.

7. In the Display Screen, drag the following fields to be displayed in the table: Order ID, Quantity, Unit Price, and Total one by one. Click Next.
8. In the Group screen, add **Product Name** as the group by field.

9. Click **Style** to switch to the screen and select **Commercial** from the style list. Click **Finish** to create the table.

10. Resize the group by field to make sure all the product names can be shown completely. The table displays as follows:

11. Click **File > Save** to save the library component as **ProductOrderDetails.lc**.

Next, we will create the second library component that contains the chart.

13. In the Select Component for Library Component dialog, input Product Sales in the Library Component Title text field, select Chart as the component type and click OK. The Chart Wizard is displayed.

14. In the Data screen of the wizard, select WorldWideSalesBV, then click Next.

15. Keep the default selections in the Type screen. Click Next.

16. In the Display Screen, add Product Name to the X-Axis box and Total Sales to the Bar Length box.

17. Click Style to switch to the screen, select ClassicBlue as the chart style.

18. Click Finish to create the chart. The chart displays as follows.
19. Click File > Save to save the library component as ProductSales.lc.

**Task 2: Deliver a message between the library components**

In order for end users to view sales information by order ID in the table, we will define to deliver a built-in message 0002-Sort between the two library components. We will use the chart to send the message, and the table to receive the message.

1. Double-click any bar in the chart. The Format Bar dialog appears.

2. Switch to the Behaviors tab, select Click from the drop-down list in the Events column, then click in the Actions column.

3. In the Web Action List dialog, select the *SendMessage* action and click OK.
4. In the Send Message - Web Action Builder dialog, select the built in message 0002 - Sort from the drop-down list, then in the Value column, select Descending from the drop-down list for Sort Order.

![Send Message - Web Action Builder dialog](image)

5. Click OK to close the Send Message - Web Action Builder dialog.

6. Click OK in the Format Bar dialog to finish defining the message.

7. Click File > Save to save the library component.

Next, we will define to make the table receive the sort message that will be sent out from the chart once the click action is triggered on the chart bars.

8. Click Window > Switch Window > ProductOrderDetails.lc to switch to the table library component.

9. Select the table, right-click on it and select Receive Message from the shortcut menu.

10. In the Receive Message dialog, click + to add a message line, select the built-in message 0002 - Sort from the drop-down list of the Message ID column, then click << in the Actions column.
11. In the Sort dialog, select **Order ID** from the Sort On column and **Descending** from the Sort Value column. Click **OK** to close the dialog.

12. Click **OK** in the Receive Message dialog to finish defining the message.

13. Click **File > Save** to save the library component.

By now, the message between the chart and table is created and it is defined as follows: when any bar on the chart is clicked at runtime, the built-in message 0002 - Sort will be sent out from the chart to the table, and when the table receives the message,
Task 3: Insert a slider to filter data

To help end users easily get product sales information in a specific time period, we will insert a slider to filter on the Order Date field for the table.

1. Click Insert > Web Control > Filter Control.

2. In the Insert Filter Control dialog, select Range Slider as the control type, from the Select Fields drop-down list check Order Date, then click outside of the field drop-down list in the dialog to finish selecting field.

You can also select Customize Initial Values to customize the values you want to show on the slider. Here, we will use all the values in the Quantity field on the slider.

3. Click OK to insert the slider. The slider displays as follows in the library component:
Task 4: Use text field in the configuration panel to change property value

In this task, we will insert a text field into the configuration panel of the table library component and bind the Change Property web behavior to it so that end users can use the text field to dynamically change the background color of the Quantity field at runtime.

1. Check the Display Configuration Panel checkbox on the top-right corner to display the panel.

2. Click Insert > Web Control > Text Field to insert it in the configuration panel.

3. Right-click the text field and select Web Behaviors > Change Property from the shortcut menu. The Change Property - Web Behavior dialog appears.

4. Select Quantity from the Apply Action To drop-down list, Background from the Properties drop-down list, and TextField from the Value drop-down list, then click OK.

4. Click File > Save to save the library component.
Then at runtime, end users can input a hexadecimal RGB value in the text field to change the background color of the Quantity field in JDashboard.

Next we will add a label ahead of the text field to help end users identify what it is used for.

5. Click Insert > Label to add a label ahead of the text field.

6. Double-click the label and edit its text to Background Color of Quantity. Resize the label to make the whole text in it shown.

The label and text field display as follows in the configuration panel:

7. Click File > Save to save the library component.
Track 5: Publishing, Running and Administering Resources

In this track it is assumed that you are a report administrator. You need to receive the reports and library components which are designed in JReport Designer from the report developers and publish them to JReport Server so the end users can access them and view them.

In this track you perform the following lessons:

- Lesson 1: Starting JReport Server
- Lesson 2: Publishing Resources
- Lesson 3: Running Reports
- Lesson 4: Scheduling Reports
- Lesson 5: Administration of Resources
- Lesson 6: Security

Click the right arrow (→) below to begin reading the track.
Lesson 1: Starting JReport Server

In this lesson, you will learn how to start JReport Server, open the JReport Server user console, and learn the other resource control commands available on the user console.

The JReport Server user console has an easy-to-use web-based interface for selecting, viewing and editing resources. Internet Explorer, Firefox, Google Chrome, Edge, and Safari are browsers that have been certified to work with JReport products. However other browsers should also work fine.

The lesson assumes that you have installed JReport Server with its default configuration. If you changed the default locations or port numbers using Custom Installation, then you will need to adjust the instructions in this lesson accordingly.

To start JReport Server and access the user console locally, follow these steps:

1. Click Start > JReport 15 > Start Server to start JReport Server.

2. The Welcome to JReport page is automatically displayed on your default web browser. Enter admin for the user name and admin for the password, then click Login.

   These are the initial user credentials built in to JReport Server. One of the first things an administrator should do is to set up the correct user credentials so that appropriate reports can be accessed by each user.

3. The JReport Server Start Page is displayed which provides quick entries to some key functions of JReport Server.
4. Click **Public Reports** in the Open category to go to the public report directory on the user console.

By default, the User Directory panel is hidden on the left showing the folders of published resources that are available to the current login user.
5. Click **SampleReports**. The resource list, along with pertinent information, is displayed.

6. Focus on any of the resource rows, a floating toolbar is then displayed, which would contain all or some of the following commands, depending on the type of the resource:
Run

- Runs the report in the default format. If Report Studio is the default format, a web report will be opened in the View Mode of Web Report Studio and a page report in the Basic View of Page Report Studio.

- Runs the dashboard in the view mode of JDashboard.

- Runs the Visual Analysis template.

Advanced Run

Runs the report immediately after collecting additional specifications from you, including which report tab to run for a page report, what output format to use, which style group to apply, and any encoding options.

Edit

- Runs the report in the default format. If Report Studio is the default format, a web report will be opened in the Edit Mode of Web Report Studio and a page report in the Interactive View of Page Report Studio.

- Runs the dashboard in the edit mode of JDashboard.

Schedule

Runs the report based on a schedule. When you use Schedule to run a report, the request is placed into a queue and processed in the order submitted. The size of the queue and priority of the queue can be configured to make the most efficient use of resources. Lesson 4 describes scheduled reports.

Version
Views the resource version and scheduled/advanced run result version information.

**Properties**
Allows you to define the archive policy, security, and a description associated with the resource. Lesson 6 describes security.

**Parameter Settings**
Customizes the default parameter values for the report.

**Delete**
Deletes the resource.
Lesson 2: Publishing Resources

JReport Server is only able to run reports and use library components that have been published to it. As you saw in the previous lesson, some reports have automatically been published to JReport Server in the Public Reports folder. In this lesson, we publish the reports and library components in the JinfonetGourmetJava.cat catalog which were created in the previous tracks. If you haven’t completed those tracks or do not want to use your own, you can use the version of the JinfonetGourmetJava catalog offered by JReport Server, which is located at <install_root>\help\samples\JinfonetGourmetJava.

A report or library component must initially be published along with its catalog. Updates to the resource can be published independently, as long as the catalog associated with the resource remains published and has not changed. This allows you to quickly and easily install a change to a resource in the runtime environment.

This lesson contains the following tasks:

Task 1: Publish reports

Task 2: Publish library components

Task 1: Publish reports

1. On the JReport Console > Resources page, open the Public Reports folder.
2. Click Publish > To Local Server on the task bar of the Resources page.

The Publish to Local Server page is displayed:
3. Keep the default selected resource type Folder with Contents in the Resource Type drop-down list.
The Resource Type list allows you to specify the resource, the catalog, report, or folder with these objects, to be published to JReport Server.

4. Click the **Browse** button next to the From Folder field, and then browse to select the `<install_root>\help\samples\JinfonetGourmetJava` directory.

5. In the Resource Node Name field enter `JinfonetGourmetJava`.

6. In the Resource Description field enter `Jinfonet Gourmet Java catalog and reports`.

7. Click **OK** to publish the resources.

After the resources have been successfully published, the JinfonetGourmetJava folder is displayed in the resource tree.

8. Click the folder name `JinfonetGourmetJava` and the reports in the folder are listed:
Task 2: Publish library components

1. On the JReport Console > Resources page, open the My Components folder.

2. Click Publish > To Local Server on the task bar of the Resources page. The Publish to Local Server page is displayed.

3. Keep the default selected resource type Folder with Contents in the Resource Type drop-down list.

4. Click the Browse button next to the From Folder field, and then browse to select the `<install_root>\help\samples`
5. In the Resource Node Name field enter JinfonetGourmetJava.

6. In the Resource Description field enter Jinfonet Gourmet Java catalog and library components.

7. Click OK to publish the resources.

After the resources have been successfully published, the JinfonetGourmetJava folder is displayed in the resource tree.

8. Click the folder name JinfonetGourmetJava and the library components in the folder will be listed.
Lesson 3: Running Reports

This lesson describes how to run reports from the JReport Server user console. This lesson represents one way that end users could access and run published reports. Reports that are embedded in a Java application would not be accessed from the user console, but instead from the Java application. The interaction with the report itself however would be the same as described here.

The reports you view in this lesson are in the JinfonetGourmetJava folder, which is the folder you published them to in Lesson 2 > Task 1 of this track. Before you can view the reports, make sure you have the Execute and/or Edit permissions on them.

Task 1: Directly run a report

Task 2: Run a parameter-based report

Task 3: Run a report in Advanced mode

Task 1: Directly run a report

Direct running of reports is to use the default format setting to view the report result. By default, page reports (.cls) are opened in Page Report Studio and web reports (.wls) in Web Report Studio.

In this task, we will run a page report in the JinfonetGourmetJava folder as an example:

1. On the JReport Console page, go to the Public Reports > JinfonetGourmetJava folder.

2. Click the ShipmentDetailsbyCustomer.cls link to run the report.

   Page Report Studio then appears in a separate web browser window, with the report result for the ShipmentDetails report tab in the page report:
When you directly run a report, if the report contains parameters, you will be asked to specify the parameter values. See the next task for details.

**Task 2: Run a parameter-based report**

As you saw in the *Creating a parameter-based report* lesson, parameter-driven reports are another way to have a dynamic report. They allow the end users to specify the data that they want to see before the query is issued to the database. By only selecting the data that the report needs, the query is more efficient.

When a parameter-based report is run, JReport Server automatically displays the Enter Parameter Values dialog to prompt the user for the expected values. Default values, if included in the report template definition, are also displayed.

To run the parameter-based report:
1. In the JinfonetGourmetJava folder, click the **OrderListbyDate_Parameter.cls** link.

A new web browser window opens for you to enter the parameter values. The report template includes start date of May 1, 2015 and end date of June 1, 2015 as default. You can click **Submit** button to admit these defaults, or you can type new values to view the report.

![Screenshot of the parameter entry window](image)

2. The requested report is displayed showing only order details from May 1, 2016 8:00:00 AM to June 1, 2016 8:00:00 AM.
Task 3: Run a report in Advanced mode

The Advanced Run command allows you to specify additional properties when running a report, for example you can specify a different report format instead of the default one. Options available include Applet, HTML, PDF, Text, Excel, Postscript, Rich Text Format (RTF), XML and Page Report. In this lesson we will run the report as PDF format.

1. In the JinfonetGourmetJava folder, put the mouse pointer over the CustomerContactCard.cls report row, then click the Advanced Run button on the floating toolbar.

2. Click the Format tab and select PDF from the Select Format drop-down list, as shown below:
In this task, the additional options in the Advanced Run page are not used. However these options can be quite useful in real reporting scenarios. For example, you can specify database credentials under which the query should execute, or apply a style group so that the report has a different look.

3. Click the Finish button. According to your Adobe configuration, the report is displayed as a PDF file in your web browser, or saved into the default download folder of your browser.
Lesson 4: Scheduling Reports

In Lesson 3 of this track we ran published reports by using the Run and Advanced Run commands on the user console. Reports run in this way are on-demand reports. By contrast, JReport Server also allows reports to be scheduled, that is, automatically run at one or more designated dates and times. Scheduled reports can greatly improve the performance of the reporting service in an organization. For example, reports can be run during low network traffic times. Scheduled reports can capture a time period exactly, for example the last day of the quarter.

A scheduled report is not delivered to an end user in the same way an on-demand report is. There are six destinations for scheduled reports:

- Publish to Versioning System
- Publish to File System
- Publish to E-mail
- Publish to Printer
- Publish to Fax
- Publish to FTP

In this lesson, we explore three of these:

Example 1: Publish a report to the versioning system

Example 2: Publish a report to the file system
Example 1: Publish a report to the versioning system

The built-in JReport Server Versioning System is a virtual file system maintained by JReport Server.

In this example, we will set up a schedule to run a report immediately and specify that the generated result be kept for 7 days. Even though we run the task immediately, the report is scheduled to run through the JReport Server scheduling system. This has two advantages, the user does not need to wait for the report to finish to continue using their system and the report is run in the background so does not impact other users who are running interactive reports. Another advantage of scheduling a report is that it can be saved in the versioning system while normally on-demand reports will not be saved unless explicitly saved by the user.

1. On the JReport Console page, go to the Public Reports > JinfonetGourmetJava folder.

2. Put the mouse pointer over the OrderListbyDate_Parameter.cls report row, then click the Schedule button on the floating toolbar.

   The General tab of the Schedule page appears. The report tab OrderDetails is selected by default to be scheduled.

3. Enter ToVersion in the Schedule Name text field. Keep the default settings for other options in the tab.
4. Click **Next** to go to the Parameter tab. If desired, you can enter new parameter values or keep the default values.

5. Click **Next** to go to the Publish tab.

6. In the Publish tab, click **To Version** and then check **Publish to Versioning System**.

The publishing options appear.
7. Select the **Page Report Result** format, check the **Result Auto-delete** checkbox and set **Result Expires in 7 Days**.

8. Switch to the **Conditions** tab to specify the time when the task is to be performed.

9. In the Time sub tab, keep the default selection Run this task immediately in the Time Type drop-down list. The Time Zone field should represent your current time zone.

10. Click **Finish** to submit the task.

You can monitor the status of the report by viewing the *My Tasks page* (to access this page, click *My Tasks* on the system toolbar). Reports that are running are listed in the Running table; when complete they will be moved to the Completed table. Reports which are scheduled but have not yet run are listed in the Scheduled table.

In this example the report result is published to the built-in version folder of the report. We can view the report result as follows:

1. Put the mouse pointer over the **OrderListbyDate_Parameter.cls** report row, then click the **Version** button on the floating toolbar.

2. In the Report Result Versions table, click the **Page Report Result** link in the Result column. The full page report result is displayed.

---

**Example 2: Publish a report to the file system**
In this example, we set up a schedule to output a weekly sales report to the file system. The report is run every Sunday night so it will be available first thing on Monday morning.

1. On the JReport Console > Resources page, go to the Public Reports > JinfonetGourmetJava folder.

2. Put the mouse pointer over the CustomerContactCard.cls report row, then click the Schedule button on the floating toolbar.

3. In the General tab, enter ToPDF as the schedule name.

4. Click the Publish > To Disk tab, and then check Publish to Disk.

5. Check PDF. The PDF options appear.

   ![Publish to Disk Options](image_url)
6. Keep the default location selection Publish to Server Resource Tree and enter \CustomerContactCard.pdf in the text field below the location drop-down list. This publishes the report to the server resource tree under the name /CustomerContactCard.pdf.

The Server Disk Path is set by default to <install_root>\jreports, thus if we want to place the output file in this folder the path must start with a "/". Alternatively we can enter a full disk path if we want the file to be created outside of the server resource tree, for example, C:\temp\CustomerContactCard.pdf.

7. Select the Conditions tab to specify the time when the task is to be performed.

8. In the Time sub-tab, choose Run this task periodically from the Time Type drop-down list. Select Weekly from the Date drop-down list and define to repeat every one week on Sunday. Select At from the Time drop-down list and specify the time as 8:00 PM.
Although we won't use it in this lesson, the Notification tab allows you to specify e-mail notifications to be sent automatically when the report is finished or if it was unable to complete successfully.

9. Click Finish to submit the scheduled report request.

Since it isn't practical to wait until Sunday night to view the report in our lesson, we're going to cheat a bit and request an early version of the report.

1. Click My Tasks on the system toolbar. The report we requested above should appear as a scheduled task.

2. Put the mouse pointer over the task and click Run button on the floating toolbar to immediately schedule the report.
Now we can find the report using Windows Explorer in `<install_root>\jreports\CustomerContactCard.pdf`.

**Example 3: Publish a report to the printer**

In this example, we set up a schedule to output a form letter report to the printer on a monthly basis. The form letter is to be sent to delinquent customers.

1. On the JReport Console > Resources page, go to the Public Reports > JinfonetGourmetJava folder.

2. Put the mouse pointer over the `ProductSalesAnalysis.cls` report row, then click the Schedule button on the floating toolbar.

3. In the General tab, enter `ToPrinter` as the schedule name.

4. Click the Publish > To Printer tab, then check Publish to Printer.

5. Fill out the tab according to your requirements and the printer settings.
6. Click the **Conditions** tab, and then click the **Time** sub tab to specify the time when the task is to be performed.

7. From the Time Type drop-down list, choose Run this task periodically, select Monthly from the Date drop-down list and select to run the task on The 1st day of every 2 months at 7:00 AM.
8. Click Finish to enter the scheduled report request.

9. Click My Tasks on the system toolbar. The task is listed in the Scheduled table. You probably want to delete this entry so JReport Server does not print the report to your printer every month!
Lesson 5: Administration of Resources

JReport Server provides the administration console that allows the system analyst, report administrator, or application server administrator to manage the resources, databases, configuration, security and so on of JReport Server. This lesson describes the administrative tasks that you can perform through the administration console.

Task 1: Access the administration console

1. Click Start > JReport 15 > System Admin.

2. A browser window with the Sign in dialog is displayed. Enter admin for the user name and admin for the password, then click Login.

These are the initial administrative user credentials built in to JReport Server. One of the first things an administrator should do is to set up the correct user credentials so that appropriate access to the reports is granted.

The JReport Administration page is displayed:
Task 2: Review the Resources page

The Resources page of the administration console lists the resources that have been published to JReport Server. The resource list shown here is similar to that of the user console, however the report name is not a link so you cannot run report from the administration console.

The User Directory is hidden on the left showing the folders of published resources. By default, the root folder is open when you first log onto the administration console.

The NLS Editor button allows you to translate a report or dashboard into a different language from the original one.

Other buttons, Versions , Properties and Delete , are the same as described in Lesson 1 of this track.

Task 3: Review the Configuration page

The Configuration page allows you to configure and manage JReport Server as follows:

- **Service** - Used to set attributes of the HTTP connection.
Log - Used to configure the JReport logging system.

Performance - Used to preload particular catalogs and reports in cache so they will be faster to access the first time they are used.

LDAP - Used to configure LDAP as a security provider for JReport Server. A large number of different LDAP products are supported. In order to use them, a detailed knowledge of how to talk to your LDAP product is required.

Export - Used to configure the default settings for exporting report results to e-mail, to configure your FAX hardware and software settings. You cannot distribute reports via e-mail or fax until these settings are configured.

Connection - Used to reload the connection settings after datasource.xml file is modified when JReport Server is running.

Connection Pool - Used to keep cached connection for reuse.

Upload - Used to specify the allowed image types when end users insert images from the local file system into reports or dashboards.

Custom Fields - Used to manage user defined fields which can be used as resource properties in JReport Server.

Dashboard Listeners - Used to manage implementations of the Dashboard Listener API.

Dynamic Connections - Used to manage dynamic connections.

Dynamic Display Names - Used to manage dynamic display names for business view elements.

Organizations - Used to organize users into different groups.

E-mail Server - Used to set up the linkage to your SMTP server to enable sending report results and notifications via e-mails.

License Key - Used to update the server license with a new one.

Advanced - A miscellaneous set of options and settings.

Task 4: Understand the Monitor page

JReport Server Monitor allows system administrators to log, monitor and report on real-time system status and the performance of the JReport Server. It can be accessed via any web browser, enabling administrators to remotely monitor and manage JReport Servers.

JReport Server Monitor allows you to track the status of JReport Server, see what reports are running or have run as well as which users are accessing the system.

JReport Server Monitor is downloaded separately from JReport Server, and must be installed before this page can be used.
Task 5: Review the remaining pages

- **Security**
  Allows you to create and manage realms, users, groups, roles, privileges, and alias. This is required if you are going to use My Reports so that users will only see their own reports in the My Reports folder. For more details about security, see Lesson 6 in this track.

- **Profile**

- **Cluster**
  Allows you to set up groups of servers in a clustered environment.

- **Triggers**
  Allows you to create and manage triggers.

- **Data**
  JReport Server needs to read and write to a DBMS system to store information about the server and the available reports and report version. By default the DBMS is the 100% Java Apache Derby DBMS embedded in JReport. This can easily be changed to use your preferred DBMS such as Oracle or MySQL.

- **Cube**
  Creates and manages in-memory cubes for business views.

- **Cache**
  Allows you to cache data, reports, security objects, and images. These settings affect how quickly resources can be accessed; however, the more resources that are cached, the more memory is used and thus would harm performance rather than increase performance.
Lesson 6: Security

JReport Server provides a security system that protects the resources on the server from inappropriate access by users. In addition to controlling resource-level access, the security system can control access to certain fields or certain information based on the user’s role or group level information.

As an alternative to the built-in security system, an LDAP Server can be used for JReport Security. JReport provides interfaces to synchronize with a variety of LDAP servers as well as directly authenticate to an LDAP directory. Conversely, a Security token can be passed to JReport for authentication. JReport provides an interface for authentication.

The following tasks are covered in this lesson:

Task 1: Create a new user

Task 2: Enable auditing for the user

Task 3: Assign permissions to the user, group, or role

Task 1: Create a new user

To use JReport Server, you must have a user account, which consists of a unique user name and a password. JReport Server verifies your identity when you type your user name and your password and then log on. If your user account has been disabled or deleted, JReport Server prevents you from accessing the web services that JReport Server provides, in order to ensure that only valid users can access the resources that they have permission to see.

JReport Server comes with two built-in user accounts, which are admin and guest. The built-in user accounts cannot be deleted. The admin user account can neither be deleted nor disabled.

To create a user account:

1. On the JReport Administration page, click Security on the system toolbar, and then select User from the drop-down menu.
2. On the Security - User page, click the **New User** link.

3. Complete the New User dialog with any user information you would like to use and click **OK** to create the user.
Although it doesn’t matter for this lesson, the Publish privilege is an important aspect of user definition. Users can either be granted or denied the ability to publish resources to the JReport Server based on the checkbox.

4. The newly-created user is listed in the user table.

Users can be grouped. Often a set of users require the same security privileges. That is, everyone in the Sales organization can view the Sales reports. By creating a named group, you can efficiently manage the security of a set of users. This saves a lot of time when setting permissions. By setting permissions to the Sales group you don’t need to change anything as users are deleted and added into the sales organization. Roles are very similar to groups, you can assign users to groups and assign groups to roles then apply permission just to the roles.

You can also assign roles to users. Roles help you efficiently manage the user rights and permissions that are required to perform operations on resources. Assigning one or more roles to users gives the users all of the user rights and permissions the roles have to perform their jobs with. A role can also be assigned to other groups or roles, and hence the groups or roles will inherit the resource and folder permissions that the roles have. JReport Server comes with two built-in roles, which are administrators and everyone. The built-in roles cannot be deleted.
**Task 2: Enable auditing for the user**

JReport Server can record user access and management information in the log files by auditing the user.

To audit the user:

1. On Security - User page, locate the user you want to audit from the user table, then click the corresponding **Auditing** link in the Control column.

2. In the Auditing dialog, click the **OK** button to accept the supplied defaults.

Events are recorded in the log file.

**Task 3: Assign permissions to the user, group or role**

Permissions, associated with resources and folders which locate in the Public Reports or Public Components folder, are the rules that are granted to users, groups, and roles to control their access to resources and folders. The permissions include: Visible, Read, Write, Execute, Edit, Schedule, Delete, Grant, and Update Status.

After you set permissions on a parent folder, new resources and sub folders created in the folder inherit these permissions. If you do
not want them to inherit permissions, you can also set their permissions separately.

To set, view, change, or remove resource permissions:

1. On the JReport Administration page click Resources > Resources on the system toolbar.

2. On the Resources page, browse to the resource on which you want to set permissions.

3. Click the Properties button in the Control column of the resource.

4. In the displayed properties dialog, switch to the Permission tab, check Enable Setting Permissions, then select the role/user/group in the Selected box and check or uncheck the required permissions. If the role/user/group is not listed in the Selected box, select the corresponding radio button below the Available box, add the role/user/group to the Selected box and then assign the permissions accordingly.

To remove resource/folder permissions for all users, groups and roles, uncheck the Enable Setting Permissions option.

5. Click OK to confirm the settings.
Track 6: Integrating Reports and Dashboards

JReport reports and dashboards can be integrated into user applications by using URL or JSP (only available to page reports). You can then work on the integrated reports and dashboards as you do in JReport Server.

In this track, we will integrate some sample reports and dashboards in the /Public Reports/SampleReports folder into an application portal. The application portal allows users to easily request the integrated reports they need while accessing the applications they use. For this track, the application portal is built using frames. The links to the reports and dashboards are added in the application menu and appear on the same page that is the entry point to the application. However in most corporate settings there would be an application portal which would be used to launch the application and common reports. The techniques and code required to call the reports are identical whether it is a portal or a simple menu so the sample code can be utilized in either situation.

The following tasks are covered in the track:

Task 1: View the source for the application menu

Task 2: View the application menu

Task 1: View the source for the application menu

This track includes HTML which creates a menu on the left frame and displays the requested content in the right side frame.

1. Create a folder jag in the directory <install_root>\public_html.
2. Copy the contents in <install_root>\help\samples\JSPSamples\JinfonetGourmetJavaDemo to <install_root>\public_html\jag.
3. Open index.htm in the jag directory in your favorite editor. This HTML file simply creates two frames, namely leftFrame which displays left.htm and rightFrameSet which by default has introduction.htm in <install_root>\public_html\jag\application displayed.
4. Open left.htm in your editor. You will see it is a table with the menu items we want to present to the user.

Task 2: View the application menu
1. Start JReport Server and open a web browser to http://localhost:8888/jag/index.htm. The page is something like this:

![Image of JReport Tutorial](image)

Welcome to the JReport Sample Application

Click on the links to the left to access JReport reports and dashboards as well as the entry points to the JReport sample application.

Links to JReport reports and dashboards can be seamlessly embedded into any application interface. End users need not be made aware that they are leaving the application interface and entering the JReport interface if desired.

The features and functions you see in this sample application are only a subset of what JReport can do.

2. Click the links in the left frame to view the introduction and integrated reports and dashboards. The following details the sample each link is associated with and the JSP and HTML files that the samples call:

- **Reporting Introduction**
  
  Calls introduction.htm in `<install_root>/public_html/jag/application` to display the introduction of the application. You can also open the introduction by [http://localhost:8888/jag/application/introduction.htm](http://localhost:8888/jag/application/introduction.htm).

- **Run Web Report**
  

- **Run Web Report with Parameter**
  
  Calls runWebreportwithparameter.jsp in `<install_root>/public_html/jag/webreport` to run the
specified web report with the designated parameter value via Web Report Studio in the application. You can also open

- **Export Web Report**
  
  Calls `exportWebreport.html` in `<install_root>\public_html\jag\webreport` to show the sample in which
two buttons are provided to open the specified web report and then export it to the desired result format via Web

- **New Dashboard**
  
  Calls `newDashboard.jsp` in `<install_root>\public_html\jag\dashboard` to create a new dashboard via
JDashboard in the application. You can also open the sample by http://localhost:8888/jag/dashboard/newDashboard.jsp.

- **View Dashboard**
  
  Calls `viewDashboard.jsp` in `<install_root>\public_html\jag\dashboard` to open two specified
dashboards in the application via the view mode of JDashboard. You can also open the sample by http://localhost:8888/
jag/dashboard/viewDashboard.jsp.

- **Edit Dashboard**
  
  Calls `editDashboard.jsp` in `<install_root>\public_html\jag\dashboard` to open the specified dashboard
in the application via the edit mode of JDashboard. You can also open the sample by http://localhost:8888/jag/
dashboard/editDashboard.jsp.

- **New Visual Analysis**
  
  Calls `newVA.jsp` in `<install_root>\public_html\jag\va` to start a new visual analysis session via Visual
Analysis in the application. You can also open the sample by http://localhost:8888/jag/va/newVA.jsp.

- **Run Visual Analysis**
  
  Calls `runVA.jsp` in `<install_root>\public_html\jag\va` to open the specified analysis template via Visual
Analysis in the application. You can also open the sample by http://localhost:8888/jag/va/runVA.jsp.

- **Run Page Report**
  
  Calls `runReport.jsp` in `<install_root>\public_html\jag` to run the specified page report via Page Report
Studio in the application. You can also open the sample by http://localhost:8888/jag/runReport.jsp.

- **Run Page Report with Parameters**
  
  Calls `runWithParameter.html` in `<install_root>\public_html\jag` to request the parameter values used by
the specified page report and then runWithParameter.jsp in the same folder to run the page report via Page Report Studio in the application. You can also open the sample by http://localhost:8888/jag/runWithParameter.html.

- **Export Page Report**
  Calls exportReport.html in <install_root>/public_html/jag to show the sample in which two buttons are provided to open the specified page report and then export it to the desired result format via Page Report Studio. You can also open the sample by http://localhost:8888/jag/exportReport.html.

- **Schedule Page Report**
  Calls scheduleRequestJS.html, scheduleRequest.html and scheduleReport.jsp in <install_root>/public_html/jag to submit a schedule task in the application, which publishes the specified page report to disk in the PDF format. You can also open the sample by http://localhost:8888/jag/scheduleRequestJS.html.